aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Peter Korsgaard <jacmet@sunsite.dk>2009-03-05 14:17:55 +0000
committerGravatar Peter Korsgaard <jacmet@sunsite.dk>2009-03-05 14:17:55 +0000
commit2e1ca24a270ce8351ec0057102ef8bf03f723673 (patch)
treefe185ed25c923ed00b55252ca61d8e2661d7fd5c
parent89b4f17873d131ed69af2ab6db8aa665db5840f2 (diff)
downloadbuildroot-2e1ca24a270ce8351ec0057102ef8bf03f723673.tar.gz
buildroot-2e1ca24a270ce8351ec0057102ef8bf03f723673.tar.bz2
package: convert some Config.in selects to depends
Patch by Olaf Rempel <razzor@kopf-tisch.de>. quick grep showed theses invalid selects of toolchain options.
-rw-r--r--package/fuse/Config.in5
-rw-r--r--package/lzma/Config.in5
-rw-r--r--package/netkitbase/Config.in5
-rw-r--r--package/qtopia4/Config.in6
4 files changed, 15 insertions, 6 deletions
diff --git a/package/fuse/Config.in b/package/fuse/Config.in
index afe64fff89..dffadf8a12 100644
--- a/package/fuse/Config.in
+++ b/package/fuse/Config.in
@@ -1,7 +1,10 @@
config BR2_PACKAGE_LIBFUSE
bool "libfuse"
- select BR2_LARGEFILE
+ depends on BR2_LARGEFILE
help
FUSE (Filesystem in UserSpacE)
http://fuse.sourceforge.net/
+
+comment "libfuse requires a toolchain with LARGEFILE support"
+ depends on !BR2_LARGEFILE
diff --git a/package/lzma/Config.in b/package/lzma/Config.in
index e2e44f3d66..9ca3c02180 100644
--- a/package/lzma/Config.in
+++ b/package/lzma/Config.in
@@ -1,11 +1,14 @@
config BR2_PACKAGE_LZMA_TARGET
bool "Install lzma for the target system"
- select BR2_GCC_CROSS_CXX
+ depends on BR2_GCC_CROSS_CXX
help
lzma utils on the target
http://tukaani.org/lzma/
+comment "lzma requires a toolchain with C++ support"
+ depends on !BR2_GCC_CROSS_CXX
+
config BR2_PACKAGE_LZMA_TARGET_HEADERS
bool "lzma headers in target"
depends on BR2_PACKAGE_LZMA_TARGET
diff --git a/package/netkitbase/Config.in b/package/netkitbase/Config.in
index 410d28219f..725e500ace 100644
--- a/package/netkitbase/Config.in
+++ b/package/netkitbase/Config.in
@@ -1,7 +1,10 @@
config BR2_PACKAGE_NETKITBASE
bool "netkitbase"
- select BR2_INET_RPC
+ depends on BR2_INET_RPC
help
Old-style inetd.
ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/
+
+comment "netkitbase requires a toolchain with RPC support"
+ depends on !BR2_INET_RPC
diff --git a/package/qtopia4/Config.in b/package/qtopia4/Config.in
index 4477ee3fbe..b88d19aa18 100644
--- a/package/qtopia4/Config.in
+++ b/package/qtopia4/Config.in
@@ -1,14 +1,14 @@
config BR2_PACKAGE_QTOPIA4
bool "qtopia4"
depends on BR2_INSTALL_LIBSTDCPP
- select BR2_PTHREADS_NATIVE
+ depends on BR2_PTHREADS_NATIVE
help
Qtopia core 4.
http://www.trolltech.com/
-comment "qtopia4 requires a toolchain with C++ support enabled"
- depends on !BR2_INSTALL_LIBSTDCPP
+comment "qtopia4 requires a toolchain with C++ and NPTL support enabled"
+ depends on !BR2_INSTALL_LIBSTDCPP || !BR2_PTHREADS_NATIVE
if BR2_PACKAGE_QTOPIA4