aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Peter Korsgaard <peter@korsgaard.com>2019-02-06 16:11:15 +0100
committerGravatar Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>2019-02-06 16:31:06 +0100
commit0f32ed723e93073e77eb42fb7c886f37c4d17326 (patch)
treeb4d8af5d92f25f966b49fd9c82a1345b929e6100
parenta11d61e104bb01146b032c461a12a7340e23cae2 (diff)
downloadbuildroot-0f32ed723e93073e77eb42fb7c886f37c4d17326.tar.gz
buildroot-0f32ed723e93073e77eb42fb7c886f37c4d17326.tar.bz2
package/gpsd: remove qt support
Now that Qt4 is removed, the support in gpsd can be removed as well. Signed-off-by: Peter Korsgaard <peter@korsgaard.com> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
-rw-r--r--package/gpsd/gpsd.mk11
1 files changed, 2 insertions, 9 deletions
diff --git a/package/gpsd/gpsd.mk b/package/gpsd/gpsd.mk
index ade2d2a163..48d21348b9 100644
--- a/package/gpsd/gpsd.mk
+++ b/package/gpsd/gpsd.mk
@@ -23,7 +23,8 @@ GPSD_SCONS_OPTS = \
prefix=/usr\
sysroot=$(STAGING_DIR)\
strip=no\
- python=no
+ python=no \
+ qt=no
ifeq ($(BR2_PACKAGE_NCURSES),y)
GPSD_DEPENDENCIES += ncurses
@@ -48,14 +49,6 @@ ifeq ($(BR2_microblaze),y)
GPSD_CFLAGS += -O0
endif
-# Enable or disable Qt binding
-ifeq ($(BR2_PACKAGE_QT_NETWORK),y)
-GPSD_SCONS_ENV += QMAKE="$(QT_QMAKE)"
-GPSD_DEPENDENCIES += qt
-else
-GPSD_SCONS_OPTS += qt=no
-endif
-
# If libusb is available build it before so the package can use it
ifeq ($(BR2_PACKAGE_LIBUSB),y)
GPSD_DEPENDENCIES += libusb