summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAsgeir Bjarni Ingvarsson <asgeir@appdynamic.com>2018-07-04 20:36:24 (GMT)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>2018-07-07 22:19:37 (GMT)
commit0fe0c50d3683be4975a4551ac183707692b11215 (patch)
tree001987b0c4bbcc3e59020e72aa68532294264bae
parent3b0aa9bc18903b7fb465e525046eb5ea3867869e (diff)
downloadbuildroot-0fe0c50d3683be4975a4551ac183707692b11215.tar.gz
buildroot-0fe0c50d3683be4975a4551ac183707692b11215.tar.bz2
systemd: Fix polkit build order
We need to install polkit before systemd if we want to enable polkit integration, because systemd will not install polkit policy files unless it finds polkit-gobject-1. Signed-off-by: Asgeir Bjarni Ingvarsson <asgeir@appdynamic.com> Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
-rw-r--r--package/systemd/systemd.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/systemd/systemd.mk b/package/systemd/systemd.mk
index 10e11a9..04775ee 100644
--- a/package/systemd/systemd.mk
+++ b/package/systemd/systemd.mk
@@ -283,6 +283,7 @@ endif
ifeq ($(BR2_PACKAGE_SYSTEMD_POLKIT),y)
SYSTEMD_CONF_OPTS += -Dpolkit=true
+SYSTEMD_DEPENDENCIES += polkit
else
SYSTEMD_CONF_OPTS += -Dpolkit=false
endif