summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2017-02-15 22:20:41 (GMT)
committerPeter Korsgaard <peter@korsgaard.com>2017-02-16 14:23:57 (GMT)
commit23fa0f66a0ef05358c340adf807033db69faeb19 (patch)
tree398275456fc7a1a3d87ead6f714c62247efab1c2
parentd246cf5fd01bb0d20a0e64194ffed514ea8dd0aa (diff)
downloadbuildroot-23fa0f66a0ef05358c340adf807033db69faeb19.tar.gz
buildroot-23fa0f66a0ef05358c340adf807033db69faeb19.tar.bz2
trousers: disable on ARC
This package has been failing to build on ARC due to a toolchain bug since December 2015, causing a total of 168 build failures. Therefore, let's disable this package for now, until the toolchain issue gets resolved. Fixes^Wavoids: http://autobuild.buildroot.net/results/e65d1d7c5a4dd4616167cfe2aa938be6af139602/ Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
-rw-r--r--package/tpm-tools/Config.in2
-rw-r--r--package/trousers/Config.in3
2 files changed, 5 insertions, 0 deletions
diff --git a/package/tpm-tools/Config.in b/package/tpm-tools/Config.in
index dd59aaa..83b65f3 100644
--- a/package/tpm-tools/Config.in
+++ b/package/tpm-tools/Config.in
@@ -5,6 +5,7 @@ config BR2_PACKAGE_TPM_TOOLS
select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT_IF_LOCALE
depends on BR2_TOOLCHAIN_HAS_THREADS # trousers
depends on !BR2_STATIC_LIBS # trousers
+ depends on !BR2_arc # trousers
help
Tools to manage and diagnose a TPM
@@ -12,3 +13,4 @@ config BR2_PACKAGE_TPM_TOOLS
comment "tpm-tools needs a toolchain w/ threads, dynamic library"
depends on !BR2_TOOLCHAIN_HAS_THREADS || BR2_STATIC_LIBS
+ depends on !BR2_arc
diff --git a/package/trousers/Config.in b/package/trousers/Config.in
index 6ab74bf..11ab874 100644
--- a/package/trousers/Config.in
+++ b/package/trousers/Config.in
@@ -5,6 +5,8 @@ config BR2_PACKAGE_TROUSERS
depends on BR2_TOOLCHAIN_HAS_THREADS
# doesn't build properly in static only configurations
depends on !BR2_STATIC_LIBS
+ # broken toolchain
+ depends on !BR2_arc
help
The open-source TCG Software Stack (TSS).
@@ -16,3 +18,4 @@ config BR2_PACKAGE_TROUSERS
comment "trousers needs a toolchain w/ threads, dynamic library"
depends on !BR2_TOOLCHAIN_HAS_THREADS || BR2_STATIC_LIBS
+ depends on !BR2_arc