aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Romain Naour <romain.naour@gmail.com>2016-02-27 20:56:35 +0100
committerGravatar Peter Korsgaard <peter@korsgaard.com>2016-02-27 23:21:53 +0100
commit3fd4dde530498b67a0599b164e55773e07427701 (patch)
tree9bc4831dddbbc066fdf3d4981d74cda24d4e3c06
parent87731820926cd6f51879d7b89687bfec2e615b3d (diff)
downloadbuildroot-3fd4dde530498b67a0599b164e55773e07427701.tar.gz
buildroot-3fd4dde530498b67a0599b164e55773e07427701.tar.bz2
package/pax-utils: needs kernel headers >= 3.5
pax-utils require a toolchain with kernel headers >= 3.5 to provide PR_SET_NO_NEW_PRIVS. Fixes: http://autobuild.buildroot.net/results/a9e/a9e0287e67c03e5e385bf54578aa6c5c85206ec2 Signed-off-by: Romain Naour <romain.naour@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
-rw-r--r--package/pax-utils/Config.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/pax-utils/Config.in b/package/pax-utils/Config.in
index 58100e482a..e61d9b31f7 100644
--- a/package/pax-utils/Config.in
+++ b/package/pax-utils/Config.in
@@ -1,7 +1,11 @@
config BR2_PACKAGE_PAX_UTILS
bool "pax-utils"
+ depends on BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_5 # needs PR_SET_NO_NEW_PRIVS
help
ELF related utils for ELF 32/64 binaries that can check files
for security relevant properties.
http://www.gentoo.org/proj/en/hardened/pax-utils.xml
+
+comment "pax-utils needs a toolchain w/ headers >= 3.5"
+ depends on !BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_5