aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Romain Naour <romain.naour@gmail.com>2019-05-26 22:15:42 +0200
committerGravatar Peter Korsgaard <peter@korsgaard.com>2019-06-06 17:44:20 +0200
commit47fbfdb18f7203556530dbe28e5ba4e88fc62bbc (patch)
treec55ea89c8f5b7e1edbf019d9e8abe8a04c6c6b08
parentac4c7992786872113f4fda47fd90ec3d7efd90f7 (diff)
downloadbuildroot-47fbfdb18f7203556530dbe28e5ba4e88fc62bbc.tar.gz
buildroot-47fbfdb18f7203556530dbe28e5ba4e88fc62bbc.tar.bz2
package/gcc: don't build a toolchain for powerpc with spe ABI with gcc >= 8.x
The powerpc*-*-*spe* support has been deprecated in GCC 8 [1] and has been removed in GCC 9 [2]. While building with GCC 8, the build stop since we don't provide --enable-obsolete option. For now, keep powerpcspe support in Buildroot but only for older compiler up to GCC 7. Note: Although we can't select Glibc for powerpcspe since commit [4], this support has been removed for the next version of Glibc (the upcoming 2.30). [1] https://gcc.gnu.org/ml/gcc/2018-04/msg00102.html [2] https://gcc.gnu.org/git/?p=gcc.git;a=commitdiff;h=b31d0348ddada49453e3edaaf93a423fdc61dc79 [3] https://sourceware.org/git/?p=glibc.git;a=commit;h=a053e878494080f7070cf92890e546057236c9c9 [4] https://git.buildroot.net/buildroot/commit/?id=5777e3ffd99132a57e3d29659850eec14b1625f8 Signed-off-by: Romain Naour <romain.naour@gmail.com> Cc: Thomas Petazzoni <thomas.petazzoni@bootlin.com> Reviewed-by: Matt Weber <matthew.weber@rockwellcollins.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com> (cherry picked from commit 2df8b1417bc50f52202c6ddc21ccbfe4b109694e) Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
-rw-r--r--package/gcc/Config.in.host3
1 files changed, 3 insertions, 0 deletions
diff --git a/package/gcc/Config.in.host b/package/gcc/Config.in.host
index 8ec406a117..4934c28527 100644
--- a/package/gcc/Config.in.host
+++ b/package/gcc/Config.in.host
@@ -68,6 +68,9 @@ config BR2_GCC_VERSION_8_X
bool "gcc 8.x"
# Broken or unsupported architectures
depends on !BR2_or1k
+ # powerpc spe support has been deprecated since gcc 8.x.
+ # https://gcc.gnu.org/ml/gcc/2018-04/msg00102.html
+ depends on !BR2_powerpc_SPE
select BR2_TOOLCHAIN_GCC_AT_LEAST_8
endchoice