aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Thomas Petazzoni <thomas.petazzoni@free-electrons.com>2017-07-04 10:11:54 +0200
committerGravatar Peter Korsgaard <peter@korsgaard.com>2017-07-04 11:50:54 +0200
commit4c06d2490a07f0b88f42c56c7409899fd2f5608a (patch)
tree522a207a7887ee3fe671a9339f4cb3f7ef0c7c84
parent977063d071e4711d3562e379456736cfef18bbdd (diff)
downloadbuildroot-4c06d2490a07f0b88f42c56c7409899fd2f5608a.tar.gz
buildroot-4c06d2490a07f0b88f42c56c7409899fd2f5608a.tar.bz2
gst1-plugins-bad: fix webrtc option
When the WebRTC plugin option was introduced in commit ee267886bc090335dd94c97dca1c294addccc090 ("gst1-plugins-bad: enable webrtc plugin"), it was incorrect added as "webrtc", while the actual name of the plugin and corresponding configure option is "webrtcdsp". This commit therefore fixes the .mk file to use the correct name. And also, since we want to keep Buildroot option consistent with the name of the GStreamer plugins, it renames the Config.in option as well, and introduces the necessary Config.in.legacy handling. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
-rw-r--r--Config.in.legacy10
-rw-r--r--package/gstreamer1/gst1-plugins-bad/Config.in6
-rw-r--r--package/gstreamer1/gst1-plugins-bad/gst1-plugins-bad.mk6
3 files changed, 16 insertions, 6 deletions
diff --git a/Config.in.legacy b/Config.in.legacy
index 453c5eb8b8..ddb0ffe80d 100644
--- a/Config.in.legacy
+++ b/Config.in.legacy
@@ -145,6 +145,16 @@ endif
###############################################################################
comment "Legacy options removed in 2017.08"
+config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_WEBRTC
+ bool "gst1-plugins-bad webrtc renamed to webrtcdsp"
+ select BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_WEBRTCDSP
+ select BR2_LEGACY
+ help
+ The WebRTC plugin in GStreamer 1.x has always been named
+ webrtcdsp, but was wrongly introduced in Buildroot under the
+ name webrtc. Therefore, we have renamed the option to match
+ the actual name of the GStreamer plugin.
+
config BR2_STRIP_none
bool "Strip command 'none' has been removed"
select BR2_LEGACY
diff --git a/package/gstreamer1/gst1-plugins-bad/Config.in b/package/gstreamer1/gst1-plugins-bad/Config.in
index 17cc22be21..fd3ca938c4 100644
--- a/package/gstreamer1/gst1-plugins-bad/Config.in
+++ b/package/gstreamer1/gst1-plugins-bad/Config.in
@@ -698,8 +698,8 @@ config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_WEBP
help
Webp image format plugin
-config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_WEBRTC
- bool "webrtc"
+config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_WEBRTCDSP
+ bool "webrtcdsp"
# All depends from webrtc-audio-processing
depends on BR2_PACKAGE_WEBRTC_AUDIO_PROCESSING_ARCH_SUPPORTS
depends on BR2_INSTALL_LIBSTDCPP
@@ -710,7 +710,7 @@ config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_WEBRTC
help
WebRTC echo-cancellation, gain control and noise suppression
-comment "webrtc needs a toolchain w/ C++, NPTL, gcc >= 4.8"
+comment "webrtcdsp needs a toolchain w/ C++, NPTL, gcc >= 4.8"
depends on BR2_PACKAGE_WEBRTC_AUDIO_PROCESSING_ARCH_SUPPORTS
depends on !BR2_INSTALL_LIBSTDCPP || !BR2_TOOLCHAIN_HAS_THREADS_NPTL \
|| !BR2_TOOLCHAIN_GCC_AT_LEAST_4_8
diff --git a/package/gstreamer1/gst1-plugins-bad/gst1-plugins-bad.mk b/package/gstreamer1/gst1-plugins-bad/gst1-plugins-bad.mk
index ffc9ab4934..46dd14ccb7 100644
--- a/package/gstreamer1/gst1-plugins-bad/gst1-plugins-bad.mk
+++ b/package/gstreamer1/gst1-plugins-bad/gst1-plugins-bad.mk
@@ -813,11 +813,11 @@ else
GST1_PLUGINS_BAD_CONF_OPTS += --disable-webp
endif
-ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_WEBRTC),y)
-GST1_PLUGINS_BAD_CONF_OPTS += --enable-webrtc
+ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_WEBRTCDSP),y)
+GST1_PLUGINS_BAD_CONF_OPTS += --enable-webrtcdsp
GST1_PLUGINS_BAD_DEPENDENCIES += webrtc-audio-processing
else
-GST1_PLUGINS_BAD_CONF_OPTS += --disable-webrtc
+GST1_PLUGINS_BAD_CONF_OPTS += --disable-webrtcdsp
endif
ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_X265),y)