aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Gustavo Zacarias <gustavo@zacarias.com.ar>2015-07-29 09:40:26 -0300
committerGravatar Thomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-07-30 23:19:18 +0200
commit5f117c3db2e712a06467029ddf748ff2d77543b1 (patch)
tree1f0c22c1fd6f094a6cbd8c937ee4c185c8fc6779
parent7d6c0de238e32c184d81467767e988abc092a219 (diff)
downloadbuildroot-5f117c3.tar.gz
buildroot-5f117c3.tar.bz2
webkit: mark as deprecated
Mark webkit as deprecated now that midori has been updated to use webkitgtk24. It has multiple CVEs under it's belt and is no longer maintained upstream. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-rw-r--r--package/webkit/Config.in3
1 files changed, 3 insertions, 0 deletions
diff --git a/package/webkit/Config.in b/package/webkit/Config.in
index 2f0b90d766..7f0d1e4edb 100644
--- a/package/webkit/Config.in
+++ b/package/webkit/Config.in
@@ -5,11 +5,13 @@ config BR2_PACKAGE_WEBKIT_ARCH_SUPPORTS
default y if BR2_i386 || BR2_mips || BR2_mipsel || \
BR2_sparc || BR2_x86_64
depends on BR2_USE_MMU # libgail -> pango -> libglib2
+ depends on BR2_DEPRECATED_SINCE_2015_08
# disabled on powerpc due to bug https://bugs.webkit.org/show_bug.cgi?id=113638
config BR2_PACKAGE_WEBKIT
bool "webkit"
+ depends on BR2_DEPRECATED_SINCE_2015_08
depends on BR2_INSTALL_LIBSTDCPP
depends on BR2_USE_WCHAR # enchant -> libglib2
depends on BR2_TOOLCHAIN_HAS_THREADS # enchant -> libglib2; icu
@@ -43,6 +45,7 @@ config BR2_PACKAGE_WEBKIT
http://webkit.org/
comment "webkit needs libgtk2 and a toolchain w/ C++, wchar, threads"
+ depends on BR2_DEPRECATED_SINCE_2015_08
depends on BR2_PACKAGE_WEBKIT_ARCH_SUPPORTS
depends on BR2_ARCH_HAS_ATOMICS # cairo
depends on !BR2_PACKAGE_LIBGTK2 || !BR2_INSTALL_LIBSTDCPP || \