aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Thomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-08-04 20:00:39 +0200
committerGravatar Thomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-08-05 12:11:20 +0200
commit634b714d972590fe095736f5833e6671da8cf02b (patch)
treee7d5b2f19a8472a49309a564bf0b24f3a296324a
parent8b3fc8e07d7c4adc2c9be97850a4ef827039f2e5 (diff)
downloadbuildroot-634b714d972590fe095736f5833e6671da8cf02b.tar.gz
buildroot-634b714d972590fe095736f5833e6671da8cf02b.tar.bz2
zmqpp: update to use the gcc version dependency mechanism
This commit updates the zmqpp Config.in file to use the newly introduced gcc version dependency mechanism to depend on gcc >= 4.6 instead of open-coding dependencies on specific toolchains. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
-rw-r--r--package/zmqpp/Config.in11
1 files changed, 4 insertions, 7 deletions
diff --git a/package/zmqpp/Config.in b/package/zmqpp/Config.in
index 0aaeda3644..756c8101a3 100644
--- a/package/zmqpp/Config.in
+++ b/package/zmqpp/Config.in
@@ -1,10 +1,7 @@
config BR2_PACKAGE_ZMQPP
bool "zmqpp"
- depends on !BR2_TOOLCHAIN_EXTERNAL_BLACKFIN_UCLINUX_2014R1 # Too old gcc
- depends on !BR2_TOOLCHAIN_EXTERNAL_BLACKFIN_UCLINUX_2013R1 # Too old gcc
- depends on !BR2_TOOLCHAIN_EXTERNAL_BLACKFIN_UCLINUX_2012R2 # Too old gcc
- depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_POWERPC201103 # c++0x support
- depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_POWERPC201009 # c++0x support
+ # c++0x support
+ depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_6
depends on BR2_INSTALL_LIBSTDCPP
depends on BR2_USE_WCHAR # util-linux
depends on BR2_TOOLCHAIN_HAS_THREADS # zeromq
@@ -17,9 +14,9 @@ config BR2_PACKAGE_ZMQPP
http://github.com/benjamg/zmqpp
-comment "zmqpp needs a toolchain w/ C++, wchar, threads"
+comment "zmqpp needs a toolchain w/ C++, wchar, threads, gcc >= 4.6"
depends on !(BR2_INSTALL_LIBSTDCPP && BR2_USE_WCHAR && \
- BR2_TOOLCHAIN_HAS_THREADS)
+ BR2_TOOLCHAIN_HAS_THREADS && BR2_TOOLCHAIN_GCC_AT_LEAST_4_6)
if BR2_PACKAGE_ZMQPP