summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2010-10-29 11:50:02 (GMT)
committerPeter Korsgaard <jacmet@sunsite.dk>2010-10-29 11:50:02 (GMT)
commit6b3406a975954f40dec35ea19613b89c3f93d4d5 (patch)
tree49f93082fa469e2c3ff178e9f894d6b851e3a674
parent19e306338e7fa8fb840f93eccdce897e387739c5 (diff)
parent376dcb23adf6ff60884bd4393d1f3e2f79bc3602 (diff)
downloadbuildroot-6b3406a975954f40dec35ea19613b89c3f93d4d5.tar.gz
buildroot-6b3406a975954f40dec35ea19613b89c3f93d4d5.tar.bz2
Merge branch 'for-2010.11/gtk-bump' of git://git.busybox.net/~tpetazzoni/git/buildroot
-rw-r--r--package/Config.in1
-rw-r--r--package/Makefile.autotools.in23
-rw-r--r--package/buildroot-libtool-v1.5.patch (renamed from package/buildroot-libtool.patch)17
-rw-r--r--package/buildroot-libtool-v2.2.patch (renamed from package/multimedia/libmpd/libmpd-0.17.0-libdir-la.patch)53
-rw-r--r--package/expat/expat-libdir-la.patch77
-rw-r--r--package/expat/expat.mk1
-rw-r--r--package/freetype/freetype-2.3.9-libdir-la.patch81
-rw-r--r--package/freetype/freetype.mk1
-rw-r--r--package/gdk-pixbuf/Config.in12
-rw-r--r--package/gdk-pixbuf/gdk-pixbuf.mk51
-rw-r--r--package/libglib2/libglib2-fix-clock-gettime-check.patch51
-rw-r--r--package/libglib2/libglib2-mkenums-nowarn.patch14
-rw-r--r--package/libglib2/libglib2-optional-ipv6.patch12
-rw-r--r--package/libglib2/libglib2.mk5
-rw-r--r--package/libgtk2/Config.in9
-rw-r--r--package/libgtk2/host-libgtk2-2.20.1-reduce-dependencies.patch (renamed from package/libgtk2/host-libgtk2-2.12.12-reduce-dependencies.patch)140
-rw-r--r--package/libgtk2/libgtk2-2.12.6-configure.patch256
-rw-r--r--package/libgtk2/libgtk2-2.12.6-no-tests.patch11
-rw-r--r--package/libgtk2/libgtk2.mk17
-rw-r--r--package/libtool/libtool.mk4
-rw-r--r--package/multimedia/libmpd/libmpd.mk1
-rw-r--r--package/pango/pango.mk2
22 files changed, 179 insertions, 660 deletions
diff --git a/package/Config.in b/package/Config.in
index 3b6cd19..3693603 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -264,6 +264,7 @@ source "package/libart/Config.in"
source "package/libdrm/Config.in"
source "package/libgail/Config.in"
source "package/libglade/Config.in"
+source "package/gdk-pixbuf/Config.in"
source "package/libgtk2/Config.in"
source "package/libpng/Config.in"
source "package/librsvg/Config.in"
diff --git a/package/Makefile.autotools.in b/package/Makefile.autotools.in
index 589079b..87c3092 100644
--- a/package/Makefile.autotools.in
+++ b/package/Makefile.autotools.in
@@ -139,10 +139,16 @@ $(2)_POST_PATCH_HOOKS += UPDATE_CONFIG_HOOK
#
define LIBTOOL_PATCH_HOOK
@$(call MESSAGE,"Patching libtool")
- $(Q)if test "$$($$(PKG)_LIBTOOL_PATCH)" = "YES" -a \
- "$$($$(PKG)_AUTORECONF)" != "YES"; then \
- for i in `find $$($$(PKG)_SRCDIR) -name ltmain.sh`; do \
- toolchain/patch-kernel.sh $$$${i%/*} package buildroot-libtool.patch; \
+ $(Q)if test "$$($$(PKG)_LIBTOOL_PATCH)" = "YES" \
+ -a "$$($$(PKG)_AUTORECONF)" != "YES"; then \
+ for i in `find $$($$(PKG)_SRCDIR) -name ltmain.sh`; do \
+ ltmain_version=`sed -n '/^[ ]*VERSION=/{s/^[ ]*VERSION=//;p;q;}' $$$$i | \
+ sed -e 's/\([0-9].[0-9]*\).*/\1/' -e 's/\"//'`; \
+ if test $$$${ltmain_version} = '1.5'; then \
+ toolchain/patch-kernel.sh $$$${i%/*} package buildroot-libtool-v1.5.patch; \
+ elif test $$$${ltmain_version} = "2.2"; then\
+ toolchain/patch-kernel.sh $$$${i%/*} package buildroot-libtool-v2.2.patch; \
+ fi \
done \
fi
endef
@@ -158,9 +164,14 @@ endif
define AUTORECONF_HOOK
@$(call MESSAGE,"Autoreconfiguring")
$(Q)cd $$($$(PKG)_SRCDIR) && $(AUTORECONF) $$($$(PKG)_AUTORECONF_OPT)
- $(Q)if test "$($$(PKG)_LIBTOOL_PATCH)" = "YES"; then \
+ $(Q)if test "$$($$(PKG)_LIBTOOL_PATCH)" = "YES"; then \
for i in `find $$($$(PKG)_SRCDIR) -name ltmain.sh`; do \
- toolchain/patch-kernel.sh $${i%/*} package buildroot-libtool.patch; \
+ ltmain_version=`sed -n '/^[ ]*VERSION=/{s/^[ ]*VERSION=//;p;q;}' $$$$i | sed 's/\([0-9].[0-9]*\).*/\1/'`; \
+ if test $$$${ltmain_version} = "1.5"; then \
+ toolchain/patch-kernel.sh $$$${i%/*} package buildroot-libtool-v1.5.patch; \
+ elif test $$$${ltmain_version} = "2.2"; then\
+ toolchain/patch-kernel.sh $$$${i%/*} package buildroot-libtool-v2.2.patch; \
+ fi \
done \
fi
endef
diff --git a/package/buildroot-libtool.patch b/package/buildroot-libtool-v1.5.patch
index 277719d..57a7c58 100644
--- a/package/buildroot-libtool.patch
+++ b/package/buildroot-libtool-v1.5.patch
@@ -38,23 +38,6 @@
fi
# This is a shared library
-@@ -2889,6 +2896,16 @@ EOF
- esac
- if grep "^installed=no" $deplib > /dev/null; then
- path="$absdir/$objdir"
-+# This interferes with crosscompilation. -CL
-+# else
-+# eval libdir=`${SED} -n -e 's/^libdir=\(.*\)$/\1/p' $deplib`
-+# if test -z "$libdir"; then
-+# $echo "$modename: \`$deplib' is not a valid libtool archive" 1>&2
-+# exit 1
-+# fi
-+# if test "$absdir" != "$libdir"; then
-+# $echo "$modename: warning: \`$deplib' seems to be moved" 1>&2
-+# fi
- else
- eval libdir=`${SED} -n -e 's/^libdir=\(.*\)$/\1/p' $deplib`
- if test -z "$libdir"; then
@@ -5606,6 +5623,10 @@ fi\
# Replace all uninstalled libtool libraries with the installed ones
newdependency_libs=
diff --git a/package/multimedia/libmpd/libmpd-0.17.0-libdir-la.patch b/package/buildroot-libtool-v2.2.patch
index 561a338..0df00ae 100644
--- a/package/multimedia/libmpd/libmpd-0.17.0-libdir-la.patch
+++ b/package/buildroot-libtool-v2.2.patch
@@ -1,23 +1,17 @@
----
- ltmain.sh | 39 +++++++++++++++++++++++++++++++++------
- 1 file changed, 33 insertions(+), 6 deletions(-)
-
-Index: libmpd-0.17.0/ltmain.sh
-===================================================================
---- libmpd-0.17.0.orig/ltmain.sh
-+++ libmpd-0.17.0/ltmain.sh
-@@ -1056,7 +1056,9 @@
+--- a/ltmain.sh 2009-11-16 06:23:18.000000000 -0700
++++ b/ltmain.sh 2010-09-18 20:25:06.000000000 -0700
+@@ -1048,8 +1048,8 @@ func_infer_tag ()
+ # was found and let the user know that the "--tag" command
# line option must be used.
if test -z "$tagname"; then
- func_echo "unable to infer tagged configuration"
+- func_echo "unable to infer tagged configuration"
- func_fatal_error "specify a tag with \`--tag'"
-+ $echo "$modename: defaulting to \`CC'"
-+ $echo "$modename: if this is not correct, specify a tag with \`--tag'"
-+# func_fatal_error "specify a tag with \`--tag'"
++ func_echo "defaulting to \`CC'"
++ func_echo "if this is not correct, specify a tag with \`--tag'"
# else
# func_verbose "using $tagname tagged configuration"
fi
-@@ -2025,8 +2027,13 @@
+@@ -2018,8 +2018,11 @@ func_mode_install ()
# At present, this check doesn't affect windows .dll's that
# are installed into $libdir/../bin (currently, that works fine)
# but it's something to keep an eye on.
@@ -25,15 +19,13 @@ Index: libmpd-0.17.0/ltmain.sh
- func_fatal_error "error: cannot install \`$file' to a directory not ending in $libdir"
+ #
+ # This breaks install into our staging area. -PB
-+ #
-+ # if test "$inst_prefix_dir" = "$destdir"; then
-+ # $echo "$modename: error: cannot install \`$file' to a directory not ending in $libdir" 1>&2
-+ # exit $EXIT_FAILURE
-+ # fi
++ #
++ # test "$inst_prefix_dir" = "$destdir" && \
++ # func_fatal_error "error: cannot install \`$file' to a directory not ending in $libdir"
if test -n "$inst_prefix_dir"; then
# Stick the inst_prefix_dir data into the link command.
-@@ -5419,8 +5426,14 @@
+@@ -5412,8 +5415,14 @@ func_mode_link ()
absdir="$abs_ladir"
libdir="$abs_ladir"
else
@@ -50,7 +42,7 @@ Index: libmpd-0.17.0/ltmain.sh
fi
test "X$hardcode_automatic" = Xyes && avoidtemprpath=yes
else
-@@ -5571,7 +5584,7 @@
+@@ -5564,7 +5573,7 @@ func_mode_link ()
*)
if test "$installed" = no; then
notinst_deplibs="$notinst_deplibs $lib"
@@ -59,24 +51,7 @@ Index: libmpd-0.17.0/ltmain.sh
fi
;;
esac
-@@ -5901,6 +5914,16 @@
- # Add the search paths of all dependency libraries
- for deplib in $dependency_libs; do
- case $deplib in
-+# This interferes with crosscompilation. -CL
-+# else
-+# eval libdir=`${SED} -n -e 's/^libdir=\(.*\)$/\1/p' $deplib`
-+# if test -z "$libdir"; then
-+# $echo "$modename: \`$deplib' is not a valid libtool archive" 1>&2
-+# exit 1
-+# fi
-+# if test "$absdir" != "$libdir"; then
-+# $echo "$modename: warning: \`$deplib' seems to be moved" 1>&2
-+# fi
- -L*) path="$deplib" ;;
- *.la)
- func_dirname "$deplib" "" "."
-@@ -8059,6 +8082,10 @@
+@@ -8052,6 +8061,10 @@ EOF
# Replace all uninstalled libtool libraries with the installed ones
newdependency_libs=
for deplib in $dependency_libs; do
diff --git a/package/expat/expat-libdir-la.patch b/package/expat/expat-libdir-la.patch
deleted file mode 100644
index 1c8930e..0000000
--- a/package/expat/expat-libdir-la.patch
+++ /dev/null
@@ -1,77 +0,0 @@
---- expat-2.0.0/conftools/ltmain.sh.orig 2007-01-13 14:39:51.000000000 -0700
-+++ expat-2.0.0/conftools/ltmain.sh 2007-01-13 14:39:56.000000000 -0700
-@@ -273,8 +273,9 @@
- # line option must be used.
- if test -z "$tagname"; then
- $echo "$modename: unable to infer tagged configuration"
-- $echo "$modename: specify a tag with \`--tag'" 1>&2
-- exit $EXIT_FAILURE
-+ $echo "$modename: defaulting to \`CC'"
-+ $echo "$modename: if this is not correct, specify a tag with \`--tag'"
-+# exit $EXIT_FAILURE
- # else
- # $echo "$modename: using $tagname tagged configuration"
- fi
-@@ -2404,8 +2405,14 @@
- absdir="$abs_ladir"
- libdir="$abs_ladir"
- else
-- dir="$libdir"
-- absdir="$libdir"
-+ # Adding 'libdir' from the .la file to our library search paths
-+ # breaks crosscompilation horribly. We cheat here and don't add
-+ # it, instead adding the path where we found the .la. -CL
-+ dir="$abs_ladir"
-+ absdir="$abs_ladir"
-+ libdir="$abs_ladir"
-+ #dir="$libdir"
-+ #absdir="$libdir"
- fi
- test "X$hardcode_automatic" = Xyes && avoidtemprpath=yes
- else
-@@ -2886,6 +2893,16 @@
- esac
- if grep "^installed=no" $deplib > /dev/null; then
- path="$absdir/$objdir"
-+# This interferes with crosscompilation. -CL
-+# else
-+# eval libdir=`${SED} -n -e 's/^libdir=\(.*\)$/\1/p' $deplib`
-+# if test -z "$libdir"; then
-+# $echo "$modename: \`$deplib' is not a valid libtool archive" 1>&2
-+# exit 1
-+# fi
-+# if test "$absdir" != "$libdir"; then
-+# $echo "$modename: warning: \`$deplib' seems to be moved" 1>&2
-+# fi
- else
- eval libdir=`${SED} -n -e 's/^libdir=\(.*\)$/\1/p' $deplib`
- if test -z "$libdir"; then
-@@ -5598,6 +5615,10 @@
- # Replace all uninstalled libtool libraries with the installed ones
- newdependency_libs=
- for deplib in $dependency_libs; do
-+ # Replacing uninstalled with installed can easily break crosscompilation,
-+ # since the installed path is generally the wrong architecture. -CL
-+ newdependency_libs="$newdependency_libs $deplib"
-+ continue
- case $deplib in
- *.la)
- name=`$echo "X$deplib" | $Xsed -e 's%^.*/%%'`
-@@ -5919,10 +5940,13 @@
- # At present, this check doesn't affect windows .dll's that
- # are installed into $libdir/../bin (currently, that works fine)
- # but it's something to keep an eye on.
-- if test "$inst_prefix_dir" = "$destdir"; then
-- $echo "$modename: error: cannot install \`$file' to a directory not ending in $libdir" 1>&2
-- exit $EXIT_FAILURE
-- fi
-+ #
-+ # This breaks install into our staging area. -PB
-+ #
-+ # if test "$inst_prefix_dir" = "$destdir"; then
-+ # $echo "$modename: error: cannot install \`$file' to a directory not ending in $libdir" 1>&2
-+ # exit $EXIT_FAILURE
-+ # fi
-
- if test -n "$inst_prefix_dir"; then
- # Stick the inst_prefix_dir data into the link command.
diff --git a/package/expat/expat.mk b/package/expat/expat.mk
index f82a904..03b1303 100644
--- a/package/expat/expat.mk
+++ b/package/expat/expat.mk
@@ -7,7 +7,6 @@
EXPAT_VERSION = 2.0.1
EXPAT_SOURCE = expat-$(EXPAT_VERSION).tar.gz
EXPAT_SITE = http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/expat
-EXPAT_LIBTOOL_PATCH = NO
EXPAT_INSTALL_STAGING = YES
EXPAT_INSTALL_TARGET = YES
EXPAT_INSTALL_STAGING_OPT = DESTDIR=$(STAGING_DIR) installlib
diff --git a/package/freetype/freetype-2.3.9-libdir-la.patch b/package/freetype/freetype-2.3.9-libdir-la.patch
deleted file mode 100644
index 76287ef..0000000
--- a/package/freetype/freetype-2.3.9-libdir-la.patch
+++ /dev/null
@@ -1,81 +0,0 @@
-diff -urN freetype-2.3.7.orig/builds/unix/ltmain.sh freetype-2.3.7/builds/unix/ltmain.sh
---- freetype-2.3.7.orig/builds/unix/ltmain.sh 2008-09-16 15:55:36.000000000 +0100
-+++ freetype-2.3.7/builds/unix/ltmain.sh 2008-09-22 09:18:36.000000000 +0100
-@@ -1047,8 +1047,9 @@
- # was found and let the user know that the "--tag" command
- # line option must be used.
- if test -z "$tagname"; then
-- func_echo "unable to infer tagged configuration"
-- func_fatal_error "specify a tag with \`--tag'"
-+ func_echo "unable to infer tagged configuration"
-+ func_echo "$modename: defaulting to \`CC'"
-+ func_echo "$modename: if this is not correct, specify a tag with \`--tag'"
- # else
- # func_verbose "using $tagname tagged configuration"
- fi
-@@ -2017,8 +2018,11 @@
- # At present, this check doesn't affect windows .dll's that
- # are installed into $libdir/../bin (currently, that works fine)
- # but it's something to keep an eye on.
-- test "$inst_prefix_dir" = "$destdir" && \
-- func_fatal_error "error: cannot install \`$file' to a directory not ending in $libdir"
-+ #
-+ # This breaks install into our staging area. -PB
-+ #
-+ #test "$inst_prefix_dir" = "$destdir" && \
-+ # func_fatal_error "error: cannot install \`$file' to a directory not ending in $libdir"
-
- if test -n "$inst_prefix_dir"; then
- # Stick the inst_prefix_dir data into the link command.
-@@ -4885,8 +4889,14 @@
- absdir="$abs_ladir"
- libdir="$abs_ladir"
- else
-- dir="$libdir"
-- absdir="$libdir"
-+ # Adding 'libdir' from the .la file to our library search paths
-+ # breaks crosscompilation horribly. We cheat here and don't add
-+ # it, instead adding the path where we found the .la. -CL
-+ dir="$abs_ladir"
-+ absdir="$abs_ladir"
-+ libdir="$abs_ladir"
-+ #dir="$libdir"
-+ #absdir="$libdir"
- fi
- test "X$hardcode_automatic" = Xyes && avoidtemprpath=yes
- else
-@@ -5408,13 +5418,16 @@
- ;;
- esac
- else
-- eval libdir=`${SED} -n -e 's/^libdir=\(.*\)$/\1/p' $deplib`
-- test -z "$libdir" && \
-- func_fatal_error "\`$deplib' is not a valid libtool archive"
-- test "$absdir" != "$libdir" && \
-- func_warning "\`$deplib' seems to be moved"
--
-- path="-L$absdir"
-+# This interferes with crosscompilation. -CL
-+# eval libdir=`${SED} -n -e 's/^libdir=\(.*\)$/\1/p' $deplib`
-+# test -z "$libdir" && \
-+# func_fatal_error "\`$deplib' is not a valid libtool archive"
-+# test "$absdir" != "$libdir" && \
-+# func_warning "\`$deplib' seems to be moved"
-+#
-+# path="-L$absdir"
-+ path="-L$absdir/$objdir"
-+ eval libdir=`${SED} -n -e 's/^libdir=\(.*\)$/\1/p' $deplib`
- fi
- ;;
- esac
-@@ -7520,6 +7533,10 @@
- # Replace all uninstalled libtool libraries with the installed ones
- newdependency_libs=
- for deplib in $dependency_libs; do
-+ # Replacing uninstalled with installed can easily break crosscompilation,
-+ # since the installed path is generally the wrong architecture. -CL
-+ newdependency_libs="$newdependency_libs $deplib"
-+ continue
- case $deplib in
- *.la)
- func_basename "$deplib"
diff --git a/package/freetype/freetype.mk b/package/freetype/freetype.mk
index a2df1d8..c7e5c32 100644
--- a/package/freetype/freetype.mk
+++ b/package/freetype/freetype.mk
@@ -6,7 +6,6 @@
FREETYPE_VERSION = 2.3.12
FREETYPE_SITE = http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/freetype
FREETYPE_SOURCE = freetype-$(FREETYPE_VERSION).tar.bz2
-FREETYPE_LIBTOOL_PATCH = NO
FREETYPE_INSTALL_STAGING = YES
FREETYPE_INSTALL_TARGET = YES
FREETYPE_MAKE_OPT = CCexe="$(HOSTCC)"
diff --git a/package/gdk-pixbuf/Config.in b/package/gdk-pixbuf/Config.in
new file mode 100644
index 0000000..384f076
--- /dev/null
+++ b/package/gdk-pixbuf/Config.in
@@ -0,0 +1,12 @@
+config BR2_PACKAGE_GDK_PIXBUF
+ bool "gdk-pixbuf"
+ depends on BR2_USE_WCHAR # glib2
+ select BR2_PACKAGE_LIBGLIB2
+ select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT
+ select BR2_PACKAGE_LIBINTL if BR2_NEEDS_GETTEXT
+ help
+
+ Gdk-Pixbuf is an image loader and scaler. It uses GObject
+ and the GLib, to integrate well with GNOME applications.
+
+ http://www.gtk.org/
diff --git a/package/gdk-pixbuf/gdk-pixbuf.mk b/package/gdk-pixbuf/gdk-pixbuf.mk
new file mode 100644
index 0000000..4c3e108
--- /dev/null
+++ b/package/gdk-pixbuf/gdk-pixbuf.mk
@@ -0,0 +1,51 @@
+#############################################################
+#
+# gdk-pixbuf
+#
+#############################################################
+
+GDK_PIXBUF_MAJOR_VERSION = 2.22
+GDK_PIXBUF_VERSION = $(GDK_PIXBUF_MAJOR_VERSION).0
+GDK_PIXBUF_SOURCE = gdk-pixbuf-$(GDK_PIXBUF_VERSION).tar.bz2
+GDK_PIXBUF_SITE = http://ftp.gnome.org/pub/gnome/sources/gdk-pixbuf/$(GDK_PIXBUF_MAJOR_VERSION)
+GDK_PIXBUF_INSTALL_STAGING = YES
+
+GDK_PIXBUF_CONF_ENV = \
+ ac_cv_path_GLIB_GENMARSHAL=$(LIBGLIB2_HOST_BINARY) \
+ gio_can_sniff=no
+
+GDK_PIXBUF_CONF_OPT = --disable-glibtest
+
+ifneq ($(BR2_LARGEFILE),y)
+GDK_PIXBUF_CONF_OPT += --disable-largefile
+endif
+
+ifneq ($(BR2_PACKAGE_LIBPNG),y)
+GDK_PIXBUF_CONF_OPT += --without-libpng
+else
+GDK_PIXBUF_DEPENDENCIES += libpng
+endif
+
+ifneq ($(BR2_PACKAGE_JPEG),y)
+GDK_PIXBUF_CONF_OPT += --without-libjpeg
+else
+GDK_PIXBUF_DEPENDENCIES += jpeg
+endif
+
+ifneq ($(BR2_PACKAGE_TIFF),y)
+GDK_PIXBUF_CONF_OPT += --without-libtiff
+else
+GDK_PIXBUF_DEPENDENCIES += tiff
+endif
+
+GDK_PIXBUF_DEPENDENCIES += $(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),gettext libintl) host-pkg-config libglib2 libiconv
+
+$(eval $(call AUTOTARGETS,package,gdk-pixbuf))
+
+HOST_GDK_PIXBUF_CONF_OPT = \
+ --without-libjpeg \
+ --without-libtiff
+
+HOST_GDK_PIXBUF_DEPENDENCIES = host-libpng
+
+$(eval $(call AUTOTARGETS,package,gdk-pixbuf,host))
diff --git a/package/libglib2/libglib2-fix-clock-gettime-check.patch b/package/libglib2/libglib2-fix-clock-gettime-check.patch
deleted file mode 100644
index da2e485..0000000
--- a/package/libglib2/libglib2-fix-clock-gettime-check.patch
+++ /dev/null
@@ -1,51 +0,0 @@
-Rework clock_gettime() test
-
-The test for clock_gettime() in configure.in doesn't work properly
-when a previous package has loaded the shared configuration cache with
-informations about the availability of clock_gettime. A package such
-as ctorrent does so, which means that compiling ctorrent *then*
-libglib2 currently fails.
-
-According to people on the Autoconf mailing list, the libglib2 test is
-likely the one that needs to be fixed. The problem is that the
-AC_CHECK_FUNCS() test assumes that if it finds clock_gettime() it
-means that there's no need to add any -lrt flag to the
-build. Unfortunately, due to the shared configuration cache, this test
-is already done with -lrt, so the test succeeds, and libglib2 does not
-know that it needs to add -lrt to G_THREAD_LIBS and
-G_THREAD_LIBS_FOR_GTHREAD.
-
-So instead, we remplace the test with an AC_SEARCH_LIBS() test,
-followed by a test on the result of this AC_SEARCH_LIBS() test to add
-the necessary -lrt to G_THREAD_LIBS and
-G_THREAD_LIBS_FOR_GTHREAD. Therefore, even if the result for the
-AC_SEARCH_LIBS() test is cached due to the prior execution ctorrent
-./configure script, libglib2 ./configure will properly add -lrt to the
-appropriate variables.
-
-Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-
-Index: glib-2.24.1/configure.in
-===================================================================
---- glib-2.24.1.orig/configure.in 2010-08-11 19:29:20.530916023 +0200
-+++ glib-2.24.1/configure.in 2010-08-11 19:46:41.308866269 +0200
-@@ -2392,13 +2392,14 @@
- LIBS="$glib_save_LIBS"
- fi
-
--AC_CHECK_FUNCS(clock_gettime, [], [
-- AC_CHECK_LIB(rt, clock_gettime, [
-- AC_DEFINE(HAVE_CLOCK_GETTIME, 1)
-+AC_SEARCH_LIBS([clock_gettime], [rt], [
-+ AC_DEFINE(HAVE_CLOCK_GETTIME, 1,[Have clock_gettime])
-+])
-+
-+if test "$ac_cv_search_clock_gettime" = "-lrt"; then
- G_THREAD_LIBS="$G_THREAD_LIBS -lrt"
- G_THREAD_LIBS_FOR_GTHREAD="$G_THREAD_LIBS_FOR_GTHREAD -lrt"
-- ])
--])
-+fi
-
- AC_CACHE_CHECK(for monotonic clocks,
- glib_cv_monotonic_clock,AC_COMPILE_IFELSE([AC_LANG_SOURCE([[
diff --git a/package/libglib2/libglib2-mkenums-nowarn.patch b/package/libglib2/libglib2-mkenums-nowarn.patch
index 1ab6e37..d92183e 100644
--- a/package/libglib2/libglib2-mkenums-nowarn.patch
+++ b/package/libglib2/libglib2-mkenums-nowarn.patch
@@ -1,8 +1,14 @@
---- glib-2.6.5/gobject/glib-mkenums.in.orig 2006-06-15 21:28:23.436946024 -0600
-+++ glib-2.6.5/gobject/glib-mkenums.in 2006-06-15 21:28:35.417124760 -0600
+---
+ gobject/glib-mkenums.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+Index: glib-2.26.0/gobject/glib-mkenums.in
+===================================================================
+--- glib-2.26.0.orig/gobject/glib-mkenums.in
++++ glib-2.26.0/gobject/glib-mkenums.in
@@ -1,4 +1,4 @@
-#!@PERL_PATH@ -w
+#!@PERL_PATH@
- # glib-mkenums.pl
- # Information about the current enumeration
+ use File::Basename;
+ use Safe;
diff --git a/package/libglib2/libglib2-optional-ipv6.patch b/package/libglib2/libglib2-optional-ipv6.patch
index 7c511a3..8e7b418 100644
--- a/package/libglib2/libglib2-optional-ipv6.patch
+++ b/package/libglib2/libglib2-optional-ipv6.patch
@@ -5,10 +5,10 @@ Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
gio/ginetaddress.c | 9 +++++++++
1 file changed, 9 insertions(+)
-Index: glib-2.22.4/gio/ginetaddress.c
+Index: glib-2.26.0/gio/ginetaddress.c
===================================================================
---- glib-2.22.4.orig/gio/ginetaddress.c
-+++ glib-2.22.4/gio/ginetaddress.c
+--- glib-2.26.0.orig/gio/ginetaddress.c
++++ glib-2.26.0/gio/ginetaddress.c
@@ -21,6 +21,7 @@
* Samuel Cormier-Iijima <sciyoshi@gmail.com>
*/
@@ -17,7 +17,7 @@ Index: glib-2.22.4/gio/ginetaddress.c
#include <config.h>
#include <string.h>
-@@ -435,7 +436,11 @@ g_inet_address_new_from_string (const gc
+@@ -434,7 +435,11 @@
return NULL;
}
@@ -29,7 +29,7 @@ Index: glib-2.22.4/gio/ginetaddress.c
/**
* g_inet_address_new_from_bytes:
-@@ -484,8 +489,10 @@ g_inet_address_new_loopback (GSocketFami
+@@ -483,8 +488,10 @@
return g_inet_address_new_from_bytes (addr, family);
}
@@ -40,7 +40,7 @@ Index: glib-2.22.4/gio/ginetaddress.c
}
/**
-@@ -511,8 +518,10 @@ g_inet_address_new_any (GSocketFamily fa
+@@ -510,8 +517,10 @@
return g_inet_address_new_from_bytes (addr, family);
}
diff --git a/package/libglib2/libglib2.mk b/package/libglib2/libglib2.mk
index 61e8c1c..0d44d71 100644
--- a/package/libglib2/libglib2.mk
+++ b/package/libglib2/libglib2.mk
@@ -3,13 +3,12 @@
# libglib2
#
#############################################################
-LIBGLIB2_VERSION_MAJOR = 2.24
-LIBGLIB2_VERSION_MINOR = 1
+LIBGLIB2_VERSION_MAJOR = 2.26
+LIBGLIB2_VERSION_MINOR = 0
LIBGLIB2_VERSION = $(LIBGLIB2_VERSION_MAJOR).$(LIBGLIB2_VERSION_MINOR)
LIBGLIB2_SOURCE = glib-$(LIBGLIB2_VERSION).tar.bz2
LIBGLIB2_SITE = http://ftp.gnome.org/pub/gnome/sources/glib/$(LIBGLIB2_VERSION_MAJOR)
-LIBGLIB2_AUTORECONF = YES
LIBGLIB2_LIBTOOL_PATCH = NO
LIBGLIB2_INSTALL_STAGING = YES
LIBGLIB2_INSTALL_TARGET = YES
diff --git a/package/libgtk2/Config.in b/package/libgtk2/Config.in
index bc4ca9d..38b0b47 100644
--- a/package/libgtk2/Config.in
+++ b/package/libgtk2/Config.in
@@ -4,14 +4,11 @@ config BR2_PACKAGE_LIBGTK2
select BR2_PACKAGE_CAIRO
select BR2_PACKAGE_CAIRO_PS
select BR2_PACKAGE_CAIRO_PDF
+ select BR2_PACKAGE_CAIRO_SVG
select BR2_PACKAGE_LIBGLIB2
select BR2_PACKAGE_PANGO
- # libgtk2 on DirectFB is deprecated because it is no longer
- # supported in recent versions of Gtk. We will remove support
- # for Gtk over DirectFB in the next Buildroot version unless
- # support for DirectFB in mainline Gtk is improved in the mean
- # time.
- depends on BR2_PACKAGE_XORG7||(BR2_PACKAGE_DIRECTFB && BR2_DEPRECATED)
+ select BR2_PACKAGE_GDK_PIXBUF
+ depends on BR2_PACKAGE_XORG7||BR2_PACKAGE_DIRECTFB
depends on BR2_USE_WCHAR # glib2
depends on BR2_INSTALL_LIBSTDCPP # pango
help
diff --git a/package/libgtk2/host-libgtk2-2.12.12-reduce-dependencies.patch b/package/libgtk2/host-libgtk2-2.20.1-reduce-dependencies.patch
index f0ac6bf..49acf75 100644
--- a/package/libgtk2/host-libgtk2-2.12.12-reduce-dependencies.patch
+++ b/package/libgtk2/host-libgtk2-2.20.1-reduce-dependencies.patch
@@ -1,18 +1,18 @@
-Index: gtk+-2.12.12/configure.in
+Hack the configure.in file to add a "none" gdktarget which removes
+dependencies on graphic backends such as X.org or DirectFB. Gtk does
+not fully build in this mode, but it builds sufficiently to build the
+host tools that are needed to build the target Gtk.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+---
+ configure.in | 101 ++---------------------------------------------------------
+ 1 file changed, 4 insertions(+), 97 deletions(-)
+
+Index: gtk+-2.22.0/configure.in
===================================================================
---- gtk+-2.12.12.orig/configure.in 2008-09-13 02:01:07.000000000 +0200
-+++ gtk+-2.12.12/configure.in 2010-02-21 10:42:40.000000000 +0100
-@@ -32,9 +32,6 @@
-
- # required versions of other packages
- m4_define([glib_required_version], [2.13.5])
--m4_define([pango_required_version], [1.17.3])
--m4_define([atk_required_version], [1.9.0])
--m4_define([cairo_required_version], [1.2.0])
-
-
- AC_INIT([gtk+], [gtk_version],
-@@ -239,12 +236,12 @@
+--- gtk+-2.22.0.orig/configure.in
++++ gtk+-2.22.0/configure.in
+@@ -258,12 +258,12 @@
gdktarget=x11
fi
@@ -27,64 +27,29 @@ Index: gtk+-2.12.12/configure.in
*) AC_MSG_ERROR([Invalid target for GDK: use x11, quartz, directfb or win32.]);;
esac
-@@ -349,10 +346,7 @@
- ## the version requirements since those make the module lists
+@@ -373,9 +373,6 @@
## annoying to construct
PKG_CHECK_MODULES(BASE_DEPENDENCIES,
-- [glib-2.0 >= glib_required_version dnl
+ [glib-2.0 >= glib_required_version dnl
- atk >= atk_required_version dnl
- pango >= pango_required_version dnl
-- cairo >= cairo_required_version])
-+ [glib-2.0 >= glib_required_version])
+- cairo >= cairo_required_version dnl
+ gdk-pixbuf-2.0 >= gdk_pixbuf_required_version])
+
+ ## In addition to checking that cairo is present, we also need to
+@@ -388,8 +385,6 @@
+ if test "x$cairo_backend" = "xx11"; then
+ cairo_backend=xlib
+ fi
+-PKG_CHECK_MODULES(CAIRO_BACKEND,
+- [cairo-$cairo_backend >= cairo_required_version])
if test "$os_win32" != yes; then
# libtool option to control which symbols are exported
-@@ -1061,7 +1055,7 @@
- GDK_PIXBUF_XLIB_EXTRA_CFLAGS=
- GDK_PIXBUF_XLIB_EXTRA_LIBS=
-
--X_PACKAGES=fontconfig
-+X_PACKAGES=
- GDK_EXTRA_LIBS="$GDK_WLIBS"
- GDK_EXTRA_CFLAGS=
-
-@@ -1070,14 +1064,6 @@
- GTK_DEP_LIBS_FOR_X=
-
- if test "x$gdktarget" = "xx11"; then
-- #
-- # We use fontconfig very peripherally when decoding the default
-- # settings.
-- #
-- if $PKG_CONFIG --exists fontconfig; then : ; else
-- AC_MSG_ERROR([
--*** fontconfig (http://www.fontconfig.org) is required by the X11 backend.])
-- fi
-
- #
- # Check for basic X packages; we use pkg-config if available
-@@ -1124,16 +1110,6 @@
- gtk_save_LIBS=$LIBS
- LIBS="$x_libs_for_checks $LIBS"
-
-- # Sanity check for the X11 and Xext libraries. While everything we need from
-- # Xext is optional, the chances a system has *none* of these things is so
-- # small that we just unconditionally require it.
-- AC_CHECK_FUNC(XOpenDisplay, :,
-- AC_MSG_ERROR([*** libX11 not found. Check 'config.log' for more details.]))
-- AC_CHECK_FUNC(XextFindDisplay, :,
-- AC_MSG_ERROR([*** libXext not found. Check 'config.log' for more details.]))
-- AC_CHECK_FUNC(XRenderQueryExtension, :,
-- AC_MSG_ERROR([*** libXrender not found. Check 'config.log' for more details.]))
--
- # Check for xReply
-
- AC_MSG_CHECKING([if <X11/extensions/XIproto.h> is needed for xReply])
-@@ -1418,48 +1394,6 @@
- AM_CONDITIONAL(USE_DIRECTFB, false)
+@@ -1270,50 +1265,6 @@
fi
--
+
-# Check for Pango flags
-
-if test "x$gdktarget" = "xwin32"; then
@@ -122,26 +87,30 @@ Index: gtk+-2.12.12/configure.in
-CFLAGS="$saved_cflags"
-LDFLAGS="$saved_ldflags"
-
--GDK_PACKAGES="$PANGO_PACKAGES"
+-# Pull in gio-unix for GDesktopAppInfo usage, see at least gdkapplaunchcontext-x11.c
-if test "x$gdktarget" = "xx11"; then
-- GDK_PACKAGES="$GDK_PACKAGES $X_PACKAGES"
+- GDK_PACKAGES="$PANGO_PACKAGES gio-unix-2.0 $X_PACKAGES gdk-pixbuf-2.0 cairo-$cairo_backend"
+-else
+- GDK_PACKAGES="$PANGO_PACKAGES gio-2.0 gdk-pixbuf-2.0 cairo-$cairo_backend"
-fi
- GDK_DEP_LIBS="$GDK_EXTRA_LIBS `$PKG_CONFIG --libs $GDK_PIXBUF_PACKAGES $GDK_PACKAGES` $GDK_PIXBUF_EXTRA_LIBS"
- GDK_DEP_CFLAGS="`$PKG_CONFIG --cflags gthread-2.0 $GDK_PIXBUF_PACKAGES $GDK_PACKAGES` $GDK_PIXBUF_EXTRA_CFLAGS $GDK_EXTRA_CFLAGS"
-
-@@ -1468,7 +1402,7 @@
+-
+ GDK_DEP_LIBS="$GDK_EXTRA_LIBS `$PKG_CONFIG --libs $GDK_PACKAGES`"
+ GDK_DEP_CFLAGS="`$PKG_CONFIG --cflags gthread-2.0 $GDK_PACKAGES` $GDK_EXTRA_CFLAGS"
+ #
+@@ -1321,7 +1272,7 @@
# into the pkg-config files
#
if test $enable_explicit_deps != yes ; then
-- GDK_PACKAGES="$PANGO_PACKAGES"
-+ GDK_PACKAGES=
+- GDK_PACKAGES="$PANGO_PACKAGES gdk-pixbuf-2.0"
++ GDK_PACKAGES="gdk-pixbuf-2.0"
GDK_EXTRA_LIBS=
fi
-@@ -1479,39 +1413,10 @@
+@@ -1331,37 +1282,7 @@
+ AC_SUBST(GDK_DEP_LIBS)
AC_SUBST(GDK_DEP_CFLAGS)
-
+-
-########################################
-# Check for Accessibility Toolkit flags
-########################################
@@ -171,20 +140,15 @@ Index: gtk+-2.12.12/configure.in
- LIBS="$gtk_save_LIBS"
-fi
-
--GTK_PACKAGES="atk cairo"
-+GTK_PACKAGES=
- GTK_EXTRA_LIBS=
- GTK_EXTRA_CFLAGS=
--GTK_DEP_LIBS="$GDK_EXTRA_LIBS $GTK_DEP_LIBS_FOR_X `$PKG_CONFIG --libs $GDK_PIXBUF_PACKAGES $PANGO_PACKAGES $GTK_PACKAGES_FOR_X $GTK_PACKAGES` $GTK_EXTRA_LIBS $GDK_PIXBUF_EXTRA_LIBS"
-+GTK_DEP_LIBS="$GDK_EXTRA_LIBS $GTK_DEP_LIBS_FOR_X `$PKG_CONFIG --libs $GDK_PIXBUF_PACKAGES $GTK_PACKAGES_FOR_X $GTK_PACKAGES` $GTK_EXTRA_LIBS $GDK_PIXBUF_EXTRA_LIBS"
- GTK_DEP_CFLAGS="`$PKG_CONFIG --cflags gthread-2.0 $GDK_PIXBUF_PACKAGES $GDK_PACKAGES $GTK_PACKAGES` $GDK_PIXBUF_EXTRA_CFLAGS $GDK_EXTRA_CFLAGS $GTK_EXTRA_CFLAGS"
-
- if test x"$os_win32" = xyes; then
-@@ -1601,17 +1506,6 @@
-
+-GTK_PACKAGES="atk cairo gdk-pixbuf-2.0 gio-2.0"
++GTK_PACKAGES="gdk-pixbuf-2.0"
+ if test "x$gdktarget" = "xx11"; then
+ GTK_PACKAGES="$GTK_PACKAGES pangoft2"
+ fi
+@@ -1517,20 +1438,6 @@
gtk_save_cppflags="$CPPFLAGS"
- CPPFLAGS="$CPPFLAGS $GTK_DEP_CFLAGS"
--
+ CPPFLAGS="$CPPFLAGS $GTK_DEP_CFLAGS $GDK_DEP_CFLAGS"
+
-AC_CHECK_HEADER(cairo-pdf.h,,AC_MSG_ERROR([
-*** Can't find cairo-pdf.h. You must build Cairo with the pdf
-*** backend enabled.]))
@@ -193,6 +157,10 @@ Index: gtk+-2.12.12/configure.in
- AC_CHECK_HEADER(cairo-ps.h,,AC_MSG_ERROR([
-*** Can't find cairo-ps.h. You must build Cairo with the
-*** postscript backend enabled.]))
+-
+- AC_CHECK_HEADER(cairo-svg.h,,AC_MSG_ERROR([
+-*** Can't find cairo-svg.h. You must build Cairo with the
+-*** svg backend enabled.]))
-fi
-
CPPFLAGS="$gtk_save_cppflags"
diff --git a/package/libgtk2/libgtk2-2.12.6-configure.patch b/package/libgtk2/libgtk2-2.12.6-configure.patch
deleted file mode 100644
index ea60d2d..0000000
--- a/package/libgtk2/libgtk2-2.12.6-configure.patch
+++ /dev/null
@@ -1,256 +0,0 @@
-diff -urN libgtk2-2.12.6-0rig/configure libgtk2-2.12.6/configure
---- libgtk2-2.12.6-0rig/configure 2008-01-29 04:38:14.000000000 +0100
-+++ libgtk2-2.12.6/configure 2008-07-08 10:54:39.000000000 +0200
-@@ -5094,7 +5094,7 @@
- ;;
-
- # This must be Linux ELF.
--linux* | k*bsd*-gnu)
-+*-linux-gnu | linux* | k*bsd*-gnu)
- lt_cv_deplibs_check_method=pass_all
- ;;
-
-@@ -6973,7 +6973,7 @@
- lt_cv_sys_global_symbol_to_cdecl="sed -n -e 's/^T .* \(.*\)$/extern int \1();/p' -e 's/^$symcode* .* \(.*\)$/extern char \1;/p'"
- lt_cv_sys_global_symbol_to_c_name_address="sed -n -e 's/^: \([^ ]*\) $/ {\\\"\1\\\", (lt_ptr) 0},/p' -e 's/^$symcode* \([^ ]*\) \([^ ]*\)$/ {\"\2\", (lt_ptr) \&\2},/p'"
- ;;
--linux* | k*bsd*-gnu)
-+*-linux-gnu | linux* | k*bsd*-gnu)
- if test "$host_cpu" = ia64; then
- symcode='[ABCDGIRSTW]'
- lt_cv_sys_global_symbol_to_cdecl="sed -n -e 's/^T .* \(.*\)$/extern int \1();/p' -e 's/^$symcode* .* \(.*\)$/extern char \1;/p'"
-@@ -7943,7 +7943,7 @@
- lt_prog_compiler_static='-Bstatic'
- ;;
-
-- linux* | k*bsd*-gnu)
-+ *-linux-gnu | linux* | k*bsd*-gnu)
- case $cc_basename in
- icc* | ecc*)
- lt_prog_compiler_wl='-Wl,'
-@@ -8402,7 +8402,7 @@
- archive_expsym_cmds='sed "s,^,_," $export_symbols >$output_objdir/$soname.expsym~$CC -shared $pic_flag $libobjs $deplibs $compiler_flags ${wl}-h,$soname ${wl}--retain-symbols-file,$output_objdir/$soname.expsym ${wl}--image-base,`expr ${RANDOM-$$} % 4096 / 2 \* 262144 + 1342177280` -o $lib'
- ;;
-
-- gnu* | linux* | k*bsd*-gnu)
-+ *-linux-gnu | gnu* | linux* | k*bsd*-gnu)
- if $LD --help 2>&1 | grep ': supported targets:.* elf' > /dev/null; then
- tmp_addflag=
- case $cc_basename,$host_cpu in
-@@ -9336,6 +9336,7 @@
- if (lt_freq[lt_foo] == 1) { print lt_foo; }
- }'`
- sys_lib_search_path_spec=`echo $lt_search_path_spec`
-+
- else
- sys_lib_search_path_spec="/lib /usr/lib /usr/local/lib"
- fi
-@@ -9667,8 +9668,9 @@
- dynamic_linker=no
- ;;
-
-+
- # This must be Linux ELF.
--linux* | k*bsd*-gnu)
-+*-linux-gnu | linux* | k*bsd*-gnu)
- version_type=linux
- need_lib_prefix=no
- need_version=no
-@@ -9681,8 +9683,22 @@
- # Some rework will be needed to allow for fast_install
- # before this can be enabled.
- hardcode_into_libs=yes
-- sys_lib_search_path_spec="/usr/lib${libsuff} /lib${libsuff} /usr/local/lib${libsuff}"
-- sys_lib_dlsearch_path_spec="/usr/lib${libsuff} /lib${libsuff}"
-+ # sys_lib_dlsearch_path_spec="/usr/lib${libsuff} /lib${libsuff}"
-+ # Buildroot: New sys_lib_search_path_spec taken from atk!
-+if test "$GCC" = yes; then
-+ sys_lib_search_path_spec=`$CC -print-search-dirs | grep "^libraries:" | $SED -e "s/^libraries://" -e "s,=/,/,g"`
-+ if echo "$sys_lib_search_path_spec" | grep ';' >/dev/null ; then
-+ # if the path contains ";" then we assume it to be the separator
-+ # otherwise default to the standard path separator (i.e. ":") - it is
-+ # assumed that no part of a normal pathname contains ";" but that should
-+ # okay in the real world where ";" in dirpaths is itself problematic.
-+ sys_lib_search_path_spec=`echo "$sys_lib_search_path_spec" | $SED -e 's/;/ /g'`
-+ else
-+ sys_lib_search_path_spec=`echo "$sys_lib_search_path_spec" | $SED -e "s/$PATH_SEPARATOR/ /g"`
-+ fi
-+else
-+ sys_lib_search_path_spec="/lib /usr/lib /usr/local/lib"
-+fi
-
- # Append ld.so.conf contents to the search path
- if test -f /etc/ld.so.conf; then
-@@ -10780,6 +10796,7 @@
- # Now quote all the things that may contain metacharacters while being
- # careful not to overquote the AC_SUBSTed values. We take copies of the
- # variables and quote the copies for generation of the libtool script.
-+
- for var in echo old_CC old_CFLAGS AR AR_FLAGS EGREP RANLIB LN_S LTCC LTCFLAGS NM \
- SED SHELL STRIP \
- libname_spec library_names_spec soname_spec extract_expsyms_cmds \
-@@ -12109,7 +12126,7 @@
- hardcode_libdir_flag_spec_CXX='${wl}-rpath ${wl}$libdir'
- hardcode_libdir_separator_CXX=:
- ;;
-- linux* | k*bsd*-gnu)
-+ *-linux-gnu | linux* | k*bsd*-gnu)
- case $cc_basename in
- KCC*)
- # Kuck and Associates, Inc. (KAI) C++ Compiler
-@@ -12680,7 +12697,7 @@
- postdeps_CXX=
- ;;
-
--linux*)
-+*-linux-gnu | linux*)
- case `$CC -V 2>&1 | sed 5q` in
- *Sun\ C*)
- # Sun C++ 5.9
-@@ -12884,7 +12901,7 @@
- ;;
- esac
- ;;
-- linux* | k*bsd*-gnu)
-+ *-linux-gnu | linux* | k*bsd*-gnu)
- case $cc_basename in
- KCC*)
- # KAI C++ Compiler
-@@ -13636,7 +13653,7 @@
- ;;
-
- # This must be Linux ELF.
--linux* | k*bsd*-gnu)
-+*-linux-gnu | linux* | k*bsd*-gnu)
- version_type=linux
- need_lib_prefix=no
- need_version=no
-@@ -13649,7 +13666,24 @@
- # Some rework will be needed to allow for fast_install
- # before this can be enabled.
- hardcode_into_libs=yes
-- sys_lib_search_path_spec="/usr/lib${libsuff} /lib${libsuff} /usr/local/lib${libsuff}"
-+
-+ # sys_lib_search_path_spec="/usr/lib${libsuff} /lib${libsuff} /usr/local/lib${libsuff}"
-+ # Buildroot: New sys_lib_search_path_spec taken from atk!
-+if test "$GCC" = yes; then
-+ sys_lib_search_path_spec=`$CC -print-search-dirs | grep "^libraries:" | $SED -e "s/^libraries://" -e "s,=/,/,g"`
-+ if echo "$sys_lib_search_path_spec" | grep ';' >/dev/null ; then
-+ # if the path contains ";" then we assume it to be the separator
-+ # otherwise default to the standard path separator (i.e. ":") - it is
-+ # assumed that no part of a normal pathname contains ";" but that should
-+ # okay in the real world where ";" in dirpaths is itself problematic.
-+ sys_lib_search_path_spec=`echo "$sys_lib_search_path_spec" | $SED -e 's/;/ /g'`
-+ else
-+ sys_lib_search_path_spec=`echo "$sys_lib_search_path_spec" | $SED -e "s/$PATH_SEPARATOR/ /g"`
-+ fi
-+else
-+ sys_lib_search_path_spec="/lib /usr/lib /usr/local/lib"
-+fi
-+
- sys_lib_dlsearch_path_spec="/usr/lib${libsuff} /lib${libsuff}"
-
- # Append ld.so.conf contents to the search path
-@@ -14586,7 +14620,7 @@
- lt_prog_compiler_static_F77='-Bstatic'
- ;;
-
-- linux* | k*bsd*-gnu)
-+ *-linux-gnu | linux* | k*bsd*-gnu)
- case $cc_basename in
- icc* | ecc*)
- lt_prog_compiler_wl_F77='-Wl,'
-@@ -15045,7 +15079,7 @@
- archive_expsym_cmds_F77='sed "s,^,_," $export_symbols >$output_objdir/$soname.expsym~$CC -shared $pic_flag $libobjs $deplibs $compiler_flags ${wl}-h,$soname ${wl}--retain-symbols-file,$output_objdir/$soname.expsym ${wl}--image-base,`expr ${RANDOM-$$} % 4096 / 2 \* 262144 + 1342177280` -o $lib'
- ;;
-
-- gnu* | linux* | k*bsd*-gnu)
-+ gnu* | *-linux-gnu | linux* | k*bsd*-gnu)
- if $LD --help 2>&1 | grep ': supported targets:.* elf' > /dev/null; then
- tmp_addflag=
- case $cc_basename,$host_cpu in
-@@ -16239,7 +16273,7 @@
- ;;
-
- # This must be Linux ELF.
--linux* | k*bsd*-gnu)
-+*-linux-gnu | linux* | k*bsd*-gnu)
- version_type=linux
- need_lib_prefix=no
- need_version=no
-@@ -16252,7 +16286,23 @@
- # Some rework will be needed to allow for fast_install
- # before this can be enabled.
- hardcode_into_libs=yes
-- sys_lib_search_path_spec="/usr/lib${libsuff} /lib${libsuff} /usr/local/lib${libsuff}"
-+ # sys_lib_search_path_spec="/usr/lib${libsuff} /lib${libsuff} /usr/local/lib${libsuff}"
-+ # Buildroot: New sys_lib_search_path_spec taken from atk!
-+if test "$GCC" = yes; then
-+ sys_lib_search_path_spec=`$CC -print-search-dirs | grep "^libraries:" | $SED -e "s/^libraries://" -e "s,=/,/,g"`
-+ if echo "$sys_lib_search_path_spec" | grep ';' >/dev/null ; then
-+ # if the path contains ";" then we assume it to be the separator
-+ # otherwise default to the standard path separator (i.e. ":") - it is
-+ # assumed that no part of a normal pathname contains ";" but that should
-+ # okay in the real world where ";" in dirpaths is itself problematic.
-+ sys_lib_search_path_spec=`echo "$sys_lib_search_path_spec" | $SED -e 's/;/ /g'`
-+ else
-+ sys_lib_search_path_spec=`echo "$sys_lib_search_path_spec" | $SED -e "s/$PATH_SEPARATOR/ /g"`
-+ fi
-+else
-+ sys_lib_search_path_spec="/lib /usr/lib /usr/local/lib"
-+fi
-+
- sys_lib_dlsearch_path_spec="/usr/lib${libsuff} /lib${libsuff}"
-
- # Append ld.so.conf contents to the search path
-@@ -17169,7 +17219,7 @@
- lt_prog_compiler_static_GCJ='-Bstatic'
- ;;
-
-- linux* | k*bsd*-gnu)
-+ *-linux-gnu | linux* | k*bsd*-gnu)
- case $cc_basename in
- icc* | ecc*)
- lt_prog_compiler_wl_GCJ='-Wl,'
-@@ -17628,7 +17678,7 @@
- archive_expsym_cmds_GCJ='sed "s,^,_," $export_symbols >$output_objdir/$soname.expsym~$CC -shared $pic_flag $libobjs $deplibs $compiler_flags ${wl}-h,$soname ${wl}--retain-symbols-file,$output_objdir/$soname.expsym ${wl}--image-base,`expr ${RANDOM-$$} % 4096 / 2 \* 262144 + 1342177280` -o $lib'
- ;;
-
-- gnu* | linux* | k*bsd*-gnu)
-+ gnu* | *-linux-gnu | linux* | k*bsd*-gnu)
- if $LD --help 2>&1 | grep ': supported targets:.* elf' > /dev/null; then
- tmp_addflag=
- case $cc_basename,$host_cpu in
-@@ -18842,7 +18892,7 @@
- ;;
-
- # This must be Linux ELF.
--linux* | k*bsd*-gnu)
-+*-linux-gnu | linux* | k*bsd*-gnu)
- version_type=linux
- need_lib_prefix=no
- need_version=no
-@@ -18855,7 +18905,22 @@
- # Some rework will be needed to allow for fast_install
- # before this can be enabled.
- hardcode_into_libs=yes
-- sys_lib_search_path_spec="/usr/lib${libsuff} /lib${libsuff} /usr/local/lib${libsuff}"
-+ #sys_lib_search_path_spec="/usr/lib${libsuff} /lib${libsuff} /usr/local/lib${libsuff}"
-+ # Buildroot: New sys_lib_search_path_spec taken from atk!
-+if test "$GCC" = yes; then
-+ sys_lib_search_path_spec=`$CC -print-search-dirs | grep "^libraries:" | $SED -e "s/^libraries://" -e "s,=/,/,g"`
-+ if echo "$sys_lib_search_path_spec" | grep ';' >/dev/null ; then
-+ # if the path contains ";" then we assume it to be the separator
-+ # otherwise default to the standard path separator (i.e. ":") - it is
-+ # assumed that no part of a normal pathname contains ";" but that should
-+ # okay in the real world where ";" in dirpaths is itself problematic.
-+ sys_lib_search_path_spec=`echo "$sys_lib_search_path_spec" | $SED -e 's/;/ /g'`
-+ else
-+ sys_lib_search_path_spec=`echo "$sys_lib_search_path_spec" | $SED -e "s/$PATH_SEPARATOR/ /g"`
-+ fi
-+else
-+ sys_lib_search_path_spec="/lib /usr/lib /usr/local/lib"
-+fi
- sys_lib_dlsearch_path_spec="/usr/lib${libsuff} /lib${libsuff}"
-
- # Append ld.so.conf contents to the search path
diff --git a/package/libgtk2/libgtk2-2.12.6-no-tests.patch b/package/libgtk2/libgtk2-2.12.6-no-tests.patch
deleted file mode 100644
index ea92433..0000000
--- a/package/libgtk2/libgtk2-2.12.6-no-tests.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/Makefile.in 2008-01-28 22:38:09.000000000 -0500
-+++ b/Makefile.in 2008-02-11 12:52:45.000000000 -0500
-@@ -330,7 +330,7 @@ sharedstatedir = @sharedstatedir@
- sysconfdir = @sysconfdir@
- target_alias = @target_alias@
-
--SRC_SUBDIRS = gdk-pixbuf gdk gtk modules demos tests perf contrib
-+SRC_SUBDIRS = gdk-pixbuf gdk gtk modules demos perf contrib
- SUBDIRS = po po-properties $(SRC_SUBDIRS) docs m4macros
-
- # require automake 1.4
diff --git a/package/libgtk2/libgtk2.mk b/package/libgtk2/libgtk2.mk
index d669622..e41fcc9 100644
--- a/package/libgtk2/libgtk2.mk
+++ b/package/libgtk2/libgtk2.mk
@@ -3,8 +3,8 @@
# libgtk2.0
#
#############################################################
-LIBGTK2_VERSION_MAJOR:=2.12
-LIBGTK2_VERSION_MINOR:=12
+LIBGTK2_VERSION_MAJOR:=2.22
+LIBGTK2_VERSION_MINOR:=0
LIBGTK2_VERSION = $(LIBGTK2_VERSION_MAJOR).$(LIBGTK2_VERSION_MINOR)
LIBGTK2_SOURCE = gtk+-$(LIBGTK2_VERSION).tar.bz2
@@ -72,7 +72,7 @@ LIBGTK2_CONF_OPT = --enable-shared \
--enable-explicit-deps=no \
--disable-debug
-LIBGTK2_DEPENDENCIES = host-pkg-config host-libgtk2 libglib2 cairo pango atk
+LIBGTK2_DEPENDENCIES = host-pkg-config host-libgtk2 libglib2 cairo pango atk gdk-pixbuf
ifeq ($(BR2_PACKAGE_DIRECTFB),y)
LIBGTK2_CONF_OPT += --with-gdktarget=directfb
@@ -90,11 +90,6 @@ else
LIBGTK2_CONF_OPT += --without-x
endif
-# Buildroot does not support JPEG2000 library
-ifeq ($(LIBGTK2_VERSION_MAJOR),2.15)
-LIBGTK2_CONF_OPT += --without-libjasper
-endif
-
ifeq ($(BR2_PACKAGE_LIBPNG),y)
LIBGTK2_DEPENDENCIES += libpng
else
@@ -124,7 +119,7 @@ define LIBGTK2_POST_INSTALL_TWEAKS
rm -rf $(TARGET_DIR)/usr/share/gtk-2.0/demo $(TARGET_DIR)/usr/bin/gtk-demo
endef
-LIBGTK2_POST_INSTALL_TARGET_HOOKS += LIBGTK_POST_INSTALL_TWEAKS
+LIBGTK2_POST_INSTALL_TARGET_HOOKS += LIBGTK2_POST_INSTALL_TWEAKS
# We do not build a full version of libgtk2 for the host, because that
# requires compiling Cairo, Pango, ATK and X.org for the
@@ -133,7 +128,7 @@ LIBGTK2_POST_INSTALL_TARGET_HOOKS += LIBGTK_POST_INSTALL_TWEAKS
# gtk-update-icon-cache, which are the host tools needed to build Gtk
# for the target.
-HOST_LIBGTK2_DEPENDENCIES = host-libglib2 host-libpng
+HOST_LIBGTK2_DEPENDENCIES = host-libglib2 host-libpng host-gdk-pixbuf
HOST_LIBGTK2_AUTORECONF = YES
HOST_LIBGTK2_CONF_OPT = \
--disable-static \
@@ -151,12 +146,10 @@ endef
HOST_LIBGTK2_POST_PATCH_HOOKS += HOST_LIBGTK2_PATCH_REDUCE_DEPENDENCIES_HOOK
define HOST_LIBGTK2_BUILD_CMDS
- $(HOST_MAKE_ENV) make -C $(@D)/gdk-pixbuf
$(HOST_MAKE_ENV) make -C $(@D)/gtk gtk-update-icon-cache
endef
define HOST_LIBGTK2_INSTALL_CMDS
- $(HOST_MAKE_ENV) make -C $(@D)/gdk-pixbuf install
cp $(@D)/gtk/gtk-update-icon-cache $(HOST_DIR)/usr/bin
endef
diff --git a/package/libtool/libtool.mk b/package/libtool/libtool.mk
index a996876..60fee9f 100644
--- a/package/libtool/libtool.mk
+++ b/package/libtool/libtool.mk
@@ -3,7 +3,7 @@
# libtool
#
#############################################################
-LIBTOOL_VERSION = 1.5.24
+LIBTOOL_VERSION = 2.2.10
LIBTOOL_SOURCE = libtool-$(LIBTOOL_VERSION).tar.gz
LIBTOOL_SITE = $(BR2_GNU_MIRROR)/libtool
@@ -16,6 +16,8 @@ endef
HOST_LIBTOOL_POST_INSTALL_HOOKS += HOST_LIBTOOL_CUSTOM_INSTALL
+HOST_LIBTOOL_LIBTOOL_PATCH = NO
+
$(eval $(call AUTOTARGETS,package,libtool))
$(eval $(call AUTOTARGETS,package,libtool,host))
diff --git a/package/multimedia/libmpd/libmpd.mk b/package/multimedia/libmpd/libmpd.mk
index 327f61a..47a802a 100644
--- a/package/multimedia/libmpd/libmpd.mk
+++ b/package/multimedia/libmpd/libmpd.mk
@@ -7,7 +7,6 @@ LIBMPD_VERSION = 0.17.0
LIBMPD_SOURCE = libmpd-$(LIBMPD_VERSION).tar.gz
LIBMPD_SITE = http://download.sarine.nl/download/Programs/gmpc/$(LIBMPD_VERSION)/
LIBMPD_INSTALL_STAGING = YES
-LIBMPD_LIBTOOL_PATCH = NO
LIBMPD_DEPENDENCIES = libglib2
$(eval $(call AUTOTARGETS,package/multimedia,libmpd))
diff --git a/package/pango/pango.mk b/package/pango/pango.mk
index dc04b55..373eb8b 100644
--- a/package/pango/pango.mk
+++ b/package/pango/pango.mk
@@ -4,7 +4,7 @@
#
#############################################################
PANGO_VERSION_MAJOR = 1.28
-PANGO_VERSION_MINOR = 0
+PANGO_VERSION_MINOR = 2
PANGO_VERSION = $(PANGO_VERSION_MAJOR).$(PANGO_VERSION_MINOR)
PANGO_SOURCE = pango-$(PANGO_VERSION).tar.bz2