aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Peter Korsgaard <peter@korsgaard.com>2020-04-25 11:50:06 +0200
committerGravatar Peter Korsgaard <peter@korsgaard.com>2020-04-25 11:56:03 +0200
commit74a865b1fc85352b814d032fa8725ace13f27eca (patch)
tree1b476bb2ee7b472b1753ed3f785c8bb6a221f731
parentfdd30c7daaf384eb31a767f691b0acbbe84f3d49 (diff)
downloadbuildroot-74a865b1fc85352b814d032fa8725ace13f27eca.tar.gz
buildroot-74a865b1fc85352b814d032fa8725ace13f27eca.tar.bz2
package/wireguard-linux-compat: tweak kernel-headers < 5.6 logic
The reason why the external wireguard kernel module is not allowed with kernel headers >= 5.6 is that wireguard is included in the upstream kernel since 5.6 rather than some kind of (fixable) incompatibility issue. Adjust the comment to make that clear. While we're at it, drop the redundant !5.6 dependency on the kernel headers dependency comment. If headers are older than 3.10, then they are also older than 5.6, so the statement is redundant. Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
-rw-r--r--package/wireguard-linux-compat/Config.in3
1 files changed, 1 insertions, 2 deletions
diff --git a/package/wireguard-linux-compat/Config.in b/package/wireguard-linux-compat/Config.in
index 6e41a0951b..5a323a35e5 100644
--- a/package/wireguard-linux-compat/Config.in
+++ b/package/wireguard-linux-compat/Config.in
@@ -3,7 +3,7 @@ config BR2_PACKAGE_WIREGUARD_LINUX_COMPAT
depends on BR2_LINUX_KERNEL
# kernel module requires 3.10+
depends on BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_10
- # kernel module incompatible with 5.6+
+ # kernel module in upstream linux since 5.6
depends on !BR2_TOOLCHAIN_HEADERS_AT_LEAST_5_6
help
WireGuard is an extremely simple yet fast and modern VPN
@@ -23,5 +23,4 @@ config BR2_PACKAGE_WIREGUARD_LINUX_COMPAT
comment "wireguard-linux-compat needs a toolchain w/ headers >= 3.10"
depends on BR2_LINUX_KERNEL
- depends on !BR2_TOOLCHAIN_HEADERS_AT_LEAST_5_6
depends on !BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_10