aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Thomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-08-04 20:00:38 +0200
committerGravatar Thomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-08-05 12:11:20 +0200
commit8b3fc8e07d7c4adc2c9be97850a4ef827039f2e5 (patch)
treed8fa7eff5c7a2d7b3c5661b19f3a1b3bce90028c
parente01c6f08b7b1e6e9ee203eab21c33152542315f4 (diff)
downloadbuildroot-8b3fc8e07d7c4adc2c9be97850a4ef827039f2e5.tar.gz
buildroot-8b3fc8e07d7c4adc2c9be97850a4ef827039f2e5.tar.bz2
upmpdcli: update to use the gcc version dependency mechanism
This commit updates the upmpdcli Config.in file to use the newly introduced gcc version dependency mechanism to depend on gcc >= 4.6 instead of open-coding dependencies on specific toolchains. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
-rw-r--r--package/upmpdcli/Config.in15
1 files changed, 3 insertions, 12 deletions
diff --git a/package/upmpdcli/Config.in b/package/upmpdcli/Config.in
index 0fe3d10100..848c6af849 100644
--- a/package/upmpdcli/Config.in
+++ b/package/upmpdcli/Config.in
@@ -4,11 +4,7 @@ config BR2_PACKAGE_UPMPDCLI
select BR2_PACKAGE_LIBUPNPP
depends on BR2_INSTALL_LIBSTDCPP
depends on BR2_TOOLCHAIN_HAS_THREADS # libupnpp -> libupnp
- depends on !BR2_TOOLCHAIN_EXTERNAL_BLACKFIN_UCLINUX_2014R1 # Too old gcc
- depends on !BR2_TOOLCHAIN_EXTERNAL_BLACKFIN_UCLINUX_2013R1 # Ditto
- depends on !BR2_TOOLCHAIN_EXTERNAL_BLACKFIN_UCLINUX_2012R2 # Ditto
- depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_POWERPC201103 # Ditto
- depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_POWERPC201009 # Ditto
+ depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_6
# libupnpp triggers the _gp link issue
depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201305
depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201405
@@ -19,12 +15,7 @@ config BR2_PACKAGE_UPMPDCLI
http://www.lesbonscomptes.com/upmpdcli/
-comment "upmpdcli needs a toolchain w/ C++, threads"
- depends on !BR2_TOOLCHAIN_EXTERNAL_BLACKFIN_UCLINUX_2014R1 # Too old gcc
- depends on !BR2_TOOLCHAIN_EXTERNAL_BLACKFIN_UCLINUX_2013R1 # Ditto
- depends on !BR2_TOOLCHAIN_EXTERNAL_BLACKFIN_UCLINUX_2012R2 # Ditto
- depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_POWERPC201103 # Ditto
- depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_POWERPC201009 # Ditto
+comment "upmpdcli needs a toolchain w/ C++, threads, gcc >= 4.6"
depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201305
depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201405
- depends on !BR2_INSTALL_LIBSTDCPP || !BR2_TOOLCHAIN_HAS_THREADS
+ depends on !BR2_INSTALL_LIBSTDCPP || !BR2_TOOLCHAIN_HAS_THREADS || !BR2_TOOLCHAIN_GCC_AT_LEAST_4_6