aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Valentin Korenblit <valentin.korenblit@smile.fr>2018-04-11 14:57:01 +0200
committerGravatar Thomas Petazzoni <thomas.petazzoni@bootlin.com>2018-04-12 23:31:32 +0200
commit92fda8761aa8024be53a8edb8c102d1ba6401bce (patch)
tree9acfcd2696d0af7482723c707701d52ae41969be
parentf68f4de8a9746d5861f63fcbde5d7b07604aa284 (diff)
downloadbuildroot-92fda8761aa8024be53a8edb8c102d1ba6401bce.tar.gz
buildroot-92fda8761aa8024be53a8edb8c102d1ba6401bce.tar.bz2
package/mesa3d: add dependency on elfutils for R600 with LLVM
Gallium R600 needs libelf when mesa is built with llvm support. Because of this, toolchain must use either uClibc or glibc, as musl is not currently compatible with elfutils. This patch solves: configure: error: r600 requires libelf when using llvm Fixes: http://autobuild.buildroot.org/results/8845ff0f28d3273ebe884126b85cd7c4a905d81b/ Signed-off-by: Valentin Korenblit <valentin.korenblit@smile.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
-rw-r--r--package/mesa3d/Config.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/package/mesa3d/Config.in b/package/mesa3d/Config.in
index 1476b39acc..bd3d050e29 100644
--- a/package/mesa3d/Config.in
+++ b/package/mesa3d/Config.in
@@ -97,13 +97,23 @@ config BR2_PACKAGE_MESA3D_GALLIUM_DRIVER_NOUVEAU
config BR2_PACKAGE_MESA3D_GALLIUM_DRIVER_R600
bool "Gallium Radeon R600 driver"
depends on BR2_i386 || BR2_x86_64
+ depends on !BR2_PACKAGE_MESA3D_LLVM || \
+ (BR2_PACKAGE_MESA3D_LLVM && (BR2_TOOLCHAIN_USES_UCLIBC || \
+ BR2_TOOLCHAIN_USES_GLIBC)) # elfutils
select BR2_PACKAGE_MESA3D_GALLIUM_DRIVER
select BR2_PACKAGE_LIBDRM_RADEON
select BR2_PACKAGE_LLVM_AMDGPU if BR2_PACKAGE_MESA3D_LLVM
+ select BR2_PACKAGE_ELFUTILS if BR2_PACKAGE_MESA3D_LLVM
select BR2_PACKAGE_MESA3D_NEEDS_XA
help
Driver for ATI/AMD Radeon R600/R700/HD5000/HD6000 GPUs.
+# R600 needs libelf when Mesa3D is built with LLVM support
+# musl is not currently compatible with elfutils
+comment "R600 driver needs a uClibc or glibc toolchain when llvm is enabled"
+ depends on BR2_PACKAGE_MESA3D_LLVM
+ depends on !(BR2_TOOLCHAIN_USES_UCLIBC || BR2_TOOLCHAIN_USES_GLIBC)
+
config BR2_PACKAGE_MESA3D_GALLIUM_DRIVER_SVGA
bool "Gallium vmware svga driver"
depends on BR2_i386 || BR2_x86_64