aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>2020-01-13 23:59:32 +0100
committerGravatar Yann E. MORIN <yann.morin.1998@free.fr>2020-02-02 08:53:25 +0100
commita4ba0b7bf1aa647f1ec4cd0b01700a2d6d5456f8 (patch)
tree3861c0630ee566ebceaf0a188ab1abbdb1ada3f8
parentb7a024372d7c5ccb48b8e078b08eddb5eaef1d15 (diff)
downloadbuildroot-a4ba0b7bf1aa647f1ec4cd0b01700a2d6d5456f8.tar.gz
buildroot-a4ba0b7bf1aa647f1ec4cd0b01700a2d6d5456f8.tar.bz2
toolchain/toolchain-external: warn for untested GCC/kernel version
The oldest toolchain we test in the autobuilders is the Sourcery ARM toolchain which is GCC 4.8 and kernel headers 3.13. Therefore, it is likely that we're missing the required _AT_LEAST dependencies to exclude packages that don't build with older GCC/headers. Add a comment to the custom external toolchain that warns when an untested GCC or kernel headers version is selected. Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
-rw-r--r--toolchain/toolchain-external/toolchain-external-custom/Config.in.options6
1 files changed, 6 insertions, 0 deletions
diff --git a/toolchain/toolchain-external/toolchain-external-custom/Config.in.options b/toolchain/toolchain-external/toolchain-external-custom/Config.in.options
index 665765a104..9680509a13 100644
--- a/toolchain/toolchain-external/toolchain-external-custom/Config.in.options
+++ b/toolchain/toolchain-external/toolchain-external-custom/Config.in.options
@@ -92,6 +92,9 @@ config BR2_TOOLCHAIN_EXTERNAL_GCC_OLD
endchoice
+comment "GCC older than 4.8 is not tested by Buildroot. Use at your own risk."
+ depends on !BR2_TOOLCHAIN_GCC_AT_LEAST_4_8
+
choice
bool "External toolchain kernel headers series"
default BR2_TOOLCHAIN_EXTERNAL_HEADERS_REALLY_OLD
@@ -298,6 +301,9 @@ config BR2_TOOLCHAIN_EXTERNAL_HEADERS_REALLY_OLD
endchoice
+comment "Kernel headers older than 3.13 is not tested by Buildroot. Use at your own risk."
+ depends on !BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_13
+
choice
prompt "External toolchain C library"
default BR2_TOOLCHAIN_EXTERNAL_CUSTOM_UCLIBC