aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Fabrice Fontaine <fontaine.fabrice@gmail.com>2019-05-05 14:47:31 +0200
committerGravatar Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>2019-05-10 16:37:20 +0200
commitac38d6ce9c2d00623661806650807e14d4731e52 (patch)
tree3c7b3c9d1e7a3e3a82bbd23c1d9373310f5377bd
parentbda85d89d9e6f876e6e3836e47ef4f635ed8305c (diff)
downloadbuildroot-ac38d6ce9c2d00623661806650807e14d4731e52.tar.gz
buildroot-ac38d6ce9c2d00623661806650807e14d4731e52.tar.bz2
package/qt5enginio: needs ssl
qt5enginio needs Qt5 with ssl support, a dependency could be added on BR2_PACKAGE_QT5BASE_OPENSSL but this proposal was rejected in the first iteration of this patch. Qt5 has ssl support through libressl on Qt 5.6 or openssl in latest Qt however we can't select libressl without adding a circular dependency as some packages (such as sqlcipher) force openssl through BR2_PACKAGE_OPENSSL_FORCE_LIBOPENSSL. Any solution at the Kconfig level that tries to select libressl will lead to circular dependencies. Since Qt 5.6 is more or less deprecated anyway, and since it is not tested in the autobuilders, solve this with a comment. The comment is only shown for Qt 5.6, when libressl is not selected. Note that it is also shown when qt5enginio is not selected. Fixes: - http://autobuild.buildroot.org/results/60678cab68ec9aa17184b8417b64b3b79adf428a Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
-rw-r--r--package/qt5/qt5enginio/Config.in10
1 files changed, 8 insertions, 2 deletions
diff --git a/package/qt5/qt5enginio/Config.in b/package/qt5/qt5enginio/Config.in
index 102058e7c5..ac2d13b3ab 100644
--- a/package/qt5/qt5enginio/Config.in
+++ b/package/qt5/qt5enginio/Config.in
@@ -1,9 +1,8 @@
config BR2_PACKAGE_QT5ENGINIO
bool "qt5enginio"
- select BR2_PACKAGE_OPENSSL
- select BR2_PACKAGE_QT5BASE
select BR2_PACKAGE_QT5BASE_GUI
select BR2_PACKAGE_QT5BASE_NETWORK
+ select BR2_PACKAGE_OPENSSL
help
Qt is a cross-platform application and UI framework for
developers using C++.
@@ -15,3 +14,10 @@ config BR2_PACKAGE_QT5ENGINIO
5.6 and not recommended for new design.
http://doc.qt.io/archives/qt-5.5/enginio-index.html
+
+# Forcibly selecting libressl is not possible because it is from a choice, and
+# depending on it is also not possible because we select openssl. So just a
+# a warning.
+comment "qt5enginio needs libressl for Qt5.6"
+ depends on BR2_PACKAGE_QT5_VERSION_5_6
+ depends on !BR2_PACKAGE_LIBRESSL