aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Benoît Thébaudeau <benoit@wsystem.com>2015-05-07 16:58:19 +0200
committerGravatar Peter Korsgaard <peter@korsgaard.com>2015-05-17 21:59:09 +0200
commitfa5619143da84b1f5a89737c86031b255363e993 (patch)
tree3327b137792ed43c7e64487f894a0600f571219c
parentffce535003f18a4f7fc7f0bb2a1c7fcf5d42624c (diff)
downloadbuildroot-fa5619143da84b1f5a89737c86031b255363e993.tar.gz
buildroot-fa5619143da84b1f5a89737c86031b255363e993.tar.bz2
gst1-plugins-bad: remove obsolete make rules
Commit 83e29f2656a237e2c300d523776868837d3bc646 "gst1-plugins-bad: bump version" (from 1.2.4 to 1.4.1) removed the configuration options for the cdaudio and eglglessink plugins as a consequence of their removal in 1.3.1. However, that commit did not remove the corresponding make rules, so remove them now. Signed-off-by: Benoît Thébaudeau <benoit@wsystem.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
-rw-r--r--package/gstreamer1/gst1-plugins-bad/gst1-plugins-bad.mk24
1 files changed, 0 insertions, 24 deletions
diff --git a/package/gstreamer1/gst1-plugins-bad/gst1-plugins-bad.mk b/package/gstreamer1/gst1-plugins-bad/gst1-plugins-bad.mk
index 6280fd9e38..0e00ffdc0d 100644
--- a/package/gstreamer1/gst1-plugins-bad/gst1-plugins-bad.mk
+++ b/package/gstreamer1/gst1-plugins-bad/gst1-plugins-bad.mk
@@ -544,13 +544,6 @@ else
GST1_PLUGINS_BAD_CONF_OPTS += --disable-bz2
endif
-ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_CDAUDIO),y)
-GST1_PLUGINS_BAD_CONF_OPTS += --enable-cdaudio
-GST1_PLUGINS_BAD_DEPENDENCIES += libcdaudio
-else
-GST1_PLUGINS_BAD_CONF_OPTS += --disable-cdaudio
-endif
-
ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_CURL),y)
GST1_PLUGINS_BAD_CONF_OPTS += --enable-curl
GST1_PLUGINS_BAD_DEPENDENCIES += libcurl
@@ -663,23 +656,6 @@ else
GST1_PLUGINS_BAD_CONF_OPTS += --disable-rsvg
endif
-ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_EGLGLES),y)
-GST1_PLUGINS_BAD_CONF_OPTS += --enable-eglgles
-GST1_PLUGINS_BAD_DEPENDENCIES += libegl libgles
-
-ifeq ($(BR2_PACKAGE_RPI_USERLAND),y)
-# RPI has odd locations for several required headers.
-GST1_PLUGINS_BAD_CONF_OPTS += --with-egl-window-system=rpi
-GST1_PLUGINS_BAD_CONF_ENV += \
- CFLAGS="$(TARGET_CFLAGS) \
- -I$(STAGING_DIR)/usr/include/IL \
- -I$(STAGING_DIR)/usr/include/interface/vcos/pthreads \
- -I$(STAGING_DIR)/usr/include/interface/vmcs_host/linux"
-endif
-else
-GST1_PLUGINS_BAD_CONF_OPTS += --disable-eglgles
-endif
-
ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_SDL),y)
GST1_PLUGINS_BAD_CONF_ENV += ac_cv_path_SDL_CONFIG=$(STAGING_DIR)/usr/bin/sdl-config
GST1_PLUGINS_BAD_CONF_OPTS += --enable-sdl