summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabrice Fontaine <fontaine.fabrice@gmail.com>2018-10-31 22:56:47 (GMT)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>2018-11-02 20:43:22 (GMT)
commitfb59a8857ed12813d5d6ab26ef118dc4262f869b (patch)
tree49337cb20888b5f6277bf46377d29377721b54aa
parent69c38e27a837f7a1e8b4d999c7f050dbc82e5900 (diff)
downloadbuildroot-fb59a8857ed12813d5d6ab26ef118dc4262f869b.tar.gz
buildroot-fb59a8857ed12813d5d6ab26ef118dc4262f869b.tar.bz2
package/wireshark: add lua optional dependency
- lua 5.3 or luajit is not supported - Don't specify the path to find lua as pkgconfig is used for lua (this is not the case for the other options) Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
-rw-r--r--package/wireshark/wireshark.mk9
1 files changed, 8 insertions, 1 deletions
diff --git a/package/wireshark/wireshark.mk b/package/wireshark/wireshark.mk
index 4569a86..421338f 100644
--- a/package/wireshark/wireshark.mk
+++ b/package/wireshark/wireshark.mk
@@ -22,7 +22,6 @@ WIRESHARK_CONF_OPTS = \
--without-krb5 \
--enable-static=no \
--with-libsmi=no \
- --with-lua=no \
--with-pcap=$(STAGING_DIR)/usr \
--includedir=$(STAGING_DIR)/usr/include
@@ -99,6 +98,14 @@ else
WIRESHARK_CONF_OPTS += --without-libssh
endif
+# no support for lua53 yet
+ifeq ($(BR2_PACKAGE_LUA_5_1)$(BR2_PACKAGE_LUA_5_2),y)
+WIRESHARK_CONF_OPTS += --with-lua
+WIRESHARK_DEPENDENCIES += lua
+else
+WIRESHARK_CONF_OPTS += --without-lua
+endif
+
ifeq ($(BR2_PACKAGE_SBC),y)
WIRESHARK_CONF_OPTS += --with-sbc=yes
WIRESHARK_DEPENDENCIES += sbc