aboutsummaryrefslogtreecommitdiff
path: root/Config.in.legacy
diff options
context:
space:
mode:
authorGravatar Bin Meng <bmeng.cn@gmail.com>2017-08-30 08:55:25 -0700
committerGravatar Thomas Petazzoni <thomas.petazzoni@free-electrons.com>2017-08-30 22:16:37 +0200
commit20db09895d84ce20b66432614084fd6a54d6a9bc (patch)
tree3bbf82e328b4510672bb3cf27591f3f642b64039 /Config.in.legacy
parent2a27294e9ade6130a12ced9a1f152c51431a870e (diff)
downloadbuildroot-20db09895d84ce20b66432614084fd6a54d6a9bc.tar.gz
buildroot-20db09895d84ce20b66432614084fd6a54d6a9bc.tar.bz2
package/simicsfs: remove package
Buildroot currently packages version 1.18 of simics, which is quite out of date, and does not compile with Linux 4.12+. The latest package v1.22 supports recent kernels, however that is not publicly available anymore like the older versions. In fact Simics is now moving away from the simicsfs kernel module, as the kernel module has required too much maintenance work. Users should move to the new user mode Simics agent instead. Therefore, we drop the corresponding package from Buildroot. Signed-off-by: Bin Meng <bmeng.cn@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'Config.in.legacy')
-rw-r--r--Config.in.legacy13
1 files changed, 13 insertions, 0 deletions
diff --git a/Config.in.legacy b/Config.in.legacy
index 693dc95d74..d35b409423 100644
--- a/Config.in.legacy
+++ b/Config.in.legacy
@@ -145,6 +145,19 @@ endif
###############################################################################
comment "Legacy options removed in 2017.08"
+config BR2_PACKAGE_SIMICSFS
+ bool "simicsfs support removed"
+ select BR2_LEGACY
+ help
+ Support for simicsfs kernel driver that provides access to a
+ host computer's local filesystem when the target is
+ executing within a SIMICS simulation has been removed.
+
+ Simics is now moving away from the simicsfs kernel module,
+ as the kernel module has required too much maintenance
+ work. Users should move to the user mode Simics agent
+ instead.
+
config BR2_BINUTILS_VERSION_2_26_X
bool "binutils version 2.26 support removed"
select BR2_LEGACY