aboutsummaryrefslogtreecommitdiff
path: root/Config.in.legacy
diff options
context:
space:
mode:
authorGravatar Peter Korsgaard <peter@korsgaard.com>2018-01-29 22:48:25 +0100
committerGravatar Peter Korsgaard <peter@korsgaard.com>2018-02-04 00:02:35 +0100
commit2a9b7b8a1ec0f200c6b82641512325284dee9a54 (patch)
tree633a4767369b0a0e8e76340cb132b62e6d6d85d6 /Config.in.legacy
parent94e830779fb02c0a137d9e04145a6a882b2fe14d (diff)
downloadbuildroot-2a9b7b8a1ec0f200c6b82641512325284dee9a54.tar.gz
buildroot-2a9b7b8a1ec0f200c6b82641512325284dee9a54.tar.bz2
linux-headers: drop old unsupported 3.x versions
These versions are very old and no longer supported according to https://www.kernel.org/category/releases.html, so drop them and add legacy entries. Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'Config.in.legacy')
-rw-r--r--Config.in.legacy30
1 files changed, 30 insertions, 0 deletions
diff --git a/Config.in.legacy b/Config.in.legacy
index fd8505b167..60f9148234 100644
--- a/Config.in.legacy
+++ b/Config.in.legacy
@@ -145,6 +145,36 @@ endif
###############################################################################
comment "Legacy options removed in 2018.02"
+config BR2_KERNEL_HEADERS_3_4
+ bool "kernel headers version 3.4.x are no longer supported"
+ select BR2_KERNEL_HEADERS_4_1
+ select BR2_LEGACY
+ help
+ Version 3.4.x of the Linux kernel headers are no longer
+ maintained upstream and are now removed. As an alternative,
+ version 4.1.x of the headers have been automatically
+ selected in your configuration.
+
+config BR2_KERNEL_HEADERS_3_10
+ bool "kernel headers version 3.10.x are no longer supported"
+ select BR2_KERNEL_HEADERS_4_1
+ select BR2_LEGACY
+ help
+ Version 3.10.x of the Linux kernel headers are no longer
+ maintained upstream and are now removed. As an alternative,
+ version 4.1.x of the headers have been automatically
+ selected in your configuration.
+
+config BR2_KERNEL_HEADERS_3_12
+ bool "kernel headers version 3.12.x are no longer supported"
+ select BR2_KERNEL_HEADERS_4_1
+ select BR2_LEGACY
+ help
+ Version 3.12.x of the Linux kernel headers are no longer
+ maintained upstream and are now removed. As an alternative,
+ version 4.1.x of the headers have been automatically
+ selected in your configuration.
+
config BR2_BINUTILS_VERSION_2_27_X
bool "binutils version 2.27 support removed"
select BR2_LEGACY