aboutsummaryrefslogtreecommitdiff
path: root/Config.in.legacy
diff options
context:
space:
mode:
authorGravatar Thomas De Schampheleire <patrickdepinguin@gmail.com>2014-04-30 20:18:24 +0200
committerGravatar Peter Korsgaard <peter@korsgaard.com>2014-05-01 23:35:06 +0200
commit47c2d1b485d08fc4c0643ffed3d20f3c76254808 (patch)
tree5fabca905c850131e4fabc8d7d230132fcd59b5c /Config.in.legacy
parent947ca9e1207a906960efdeb1b377be57c0f305e2 (diff)
downloadbuildroot-47c2d1b485d08fc4c0643ffed3d20f3c76254808.tar.gz
buildroot-47c2d1b485d08fc4c0643ffed3d20f3c76254808.tar.bz2
kernel headers: remove deprecated versions 3.6 and 3.7
Kernel headers versions 3.6.x and 3.7.x have been deprecated since 2013.05 and thus can be removed in 2014.05. An automatic selection of 3.8.x headers is performed in the legacy menu. An existing automatic selection of 3.6.x headers is modified to select 3.8.x. As this patch removes the last occurrances of BR2_DEPRECATED_SINCE_2013_05, the symbol is removed too. Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'Config.in.legacy')
-rw-r--r--Config.in.legacy24
1 files changed, 22 insertions, 2 deletions
diff --git a/Config.in.legacy b/Config.in.legacy
index 023dfd3f20..1eb298522e 100644
--- a/Config.in.legacy
+++ b/Config.in.legacy
@@ -101,6 +101,26 @@ endif
###############################################################################
comment "Legacy options removed in 2014.05"
+config BR2_KERNEL_HEADERS_3_6
+ bool "kernel headers version 3.6.x are no longer supported"
+ select BR2_KERNEL_HEADERS_3_8
+ select BR2_LEGACY
+ help
+ Version 3.6.x of the Linux kernel headers have been deprecated
+ for more than four buildroot releases and are now removed.
+ As an alternative, version 3.8.x of the headers have been
+ automatically selected in your configuration.
+
+config BR2_KERNEL_HEADERS_3_7
+ bool "kernel headers version 3.7.x are no longer supported"
+ select BR2_KERNEL_HEADERS_3_8
+ select BR2_LEGACY
+ help
+ Version 3.7.x of the Linux kernel headers have been deprecated
+ for more than four buildroot releases and are now removed.
+ As an alternative, version 3.8.x of the headers have been
+ automatically selected in your configuration.
+
config BR2_PACKAGE_VALA
bool "vala target package has been removed"
select BR2_LEGACY
@@ -278,12 +298,12 @@ config BR2_KERNEL_HEADERS_3_3
config BR2_KERNEL_HEADERS_3_5
bool "kernel headers version 3.5.x are no longer supported"
- select BR2_KERNEL_HEADERS_3_6
+ select BR2_KERNEL_HEADERS_3_8
select BR2_LEGACY
help
Version 3.5.x of the Linux kernel headers have been deprecated
for more than four buildroot releases and are now removed.
- As an alternative, version 3.6.x of the headers have been
+ As an alternative, version 3.8.x of the headers have been
automatically selected in your configuration.
config BR2_GDB_VERSION_7_2