aboutsummaryrefslogtreecommitdiff
path: root/Config.in.legacy
diff options
context:
space:
mode:
authorGravatar Fabrice Fontaine <fontaine.fabrice@gmail.com>2020-01-24 21:09:31 +0100
committerGravatar Yann E. MORIN <yann.morin.1998@free.fr>2020-01-26 12:40:48 +0100
commitb32efbdb0354557db48852478b99080705ba315b (patch)
tree547b907ffa542a9461e551db6eeb8b526b62fb4b /Config.in.legacy
parent0e1a39ff2688455cb390c18c3aa629ae8382f26c (diff)
downloadbuildroot-b32efbdb0354557db48852478b99080705ba315b.tar.gz
buildroot-b32efbdb0354557db48852478b99080705ba315b.tar.bz2
package/celt051: drop package
Remove celt051 package as celt has been merged into the IETF Opus codec and is now obsolete (see http://celt-codec.org/). The only reverse dependency of celt051 is spice. Opus support on spice has been added upstream 6 years ago with: https://gitlab.freedesktop.org/spice/spice/commit/ce9b714137a767b81f2d3c40b5f3ce0d5cf70fc8 Spice disabled celt by default since version 0.14.1 and: https://gitlab.freedesktop.org/spice/spice-common/commit/72b0d603e128cd3af15974fe6b3e4b56ea9c6f34 Spice evens error out, by default, if Opus is missing but not explicitly disabeld since: https://gitlab.freedesktop.org/spice/spice-common/commit/f5224738425a7e97e1c32ea85bb3b243e50d4e22 This will also fix a static build failure on spice with celt051 and opus. Fixes: - http://autobuild.buildroot.org/results/96c786f85d35f33508e9c71778043d16b87f72cd Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> [yann.morin.1998@free.fr: slight rephrasing in legacy help] Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
Diffstat (limited to 'Config.in.legacy')
-rw-r--r--Config.in.legacy10
1 files changed, 10 insertions, 0 deletions
diff --git a/Config.in.legacy b/Config.in.legacy
index 1801ec06da..4b84116e0c 100644
--- a/Config.in.legacy
+++ b/Config.in.legacy
@@ -146,6 +146,16 @@ endif
comment "Legacy options removed in 2020.02"
+config BR2_PACKAGE_CELT051
+ bool "celt051 package was removed"
+ select BR2_LEGACY
+ select BR2_PACKAGE_OPUS
+ help
+ The celt051 package was removed as it is now obsolete since
+ the CELT codec has been merged into the IETF Opus codec. As
+ a result, the opus package has been automatically selected
+ in your configuration.
+
config BR2_PACKAGE_WIREGUARD
bool "wireguard package renamed"
depends on BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_10