aboutsummaryrefslogtreecommitdiff
path: root/Makefile.legacy
diff options
context:
space:
mode:
authorGravatar Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>2012-11-12 10:08:28 +0000
committerGravatar Peter Korsgaard <jacmet@sunsite.dk>2012-11-30 12:06:40 -0800
commitebcfa987df4095a7805ff124ab648fb607c89215 (patch)
treed8fdfb8438bb9323f78d2dd9ce288d131ded957d /Makefile.legacy
parentcc6da8b28ef6b6dde2eaaaf40d21f366508221ad (diff)
downloadbuildroot-ebcfa987df4095a7805ff124ab648fb607c89215.tar.gz
buildroot-ebcfa987df4095a7805ff124ab648fb607c89215.tar.bz2
pkg-infra: introduce errors for legacy API
As discussed in the BR developer days, we want to be more strict about API changes in buildroot. I.e., we want to make it less likely that a user's customizations break down after upgrading buildroot. A first step is to make sure that the user is warned about API changes. This patch introduces Makefile.legacy and Config.in.legacy, which will issue clear error messages for such situations. Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'Makefile.legacy')
-rw-r--r--Makefile.legacy13
1 files changed, 13 insertions, 0 deletions
diff --git a/Makefile.legacy b/Makefile.legacy
new file mode 100644
index 0000000000..2e015a1e3a
--- /dev/null
+++ b/Makefile.legacy
@@ -0,0 +1,13 @@
+#
+# Makefile.legacy - support for backward compatibility
+#
+# This file contains placeholders to detect backward-compatibility problems.
+# When a buildroot "API" feature is being deprecated, a rule should be added
+# here that issues an error when the old feature is used.
+#
+# This file is not included if BR2_DEPRECATED is selected, so it is possible
+# to bypass the errors (although that's usually a bad idea).
+
+ifeq ($(BR2_LEGACY),y)
+$(error "You have legacy configuration in your .config! Please check your configuration.")
+endif