aboutsummaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorGravatar Thomas De Schampheleire <patrickdepinguin@gmail.com>2014-08-15 15:40:34 +0200
committerGravatar Thomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-08-16 09:29:59 +0200
commit3ed0eada71d4cb937d1f68c9af011aea5bff0e02 (patch)
treee88926ca5e6579a9d90e5d7f19b3c38cc0ad1d59 /Makefile
parent3cb705aa845c96e19f8b32e9994d5d319ce22930 (diff)
downloadbuildroot-3ed0eada71d4cb937d1f68c9af011aea5bff0e02.tar.gz
buildroot-3ed0eada71d4cb937d1f68c9af011aea5bff0e02.tar.bz2
Makefile: unconditionally include pkg-utils.mk
Currently, pkg-utils.mk (included via package/Makefile.in) is only included when a configuration file already exists. This means that none of the utilities it defines are available without .config. In particular: - the MESSAGE macro, causing pretty build output. Since some make targets can be run even without .config, like 'make manual', not having this pretty printing is odd. - pkgname, pkgdir: in a subsequent patch, these functions will be used for the generation of the manual, and since this should work also without .config, we need these functions to be available. This patch moves the include of pkg-utils.mk from package/Makefile.in to Makefile, outside of the check for .config. This is a quick fix. The full solution involves to minimize the amount of Makefile code that is guarded by a check on .config. This approach will be taken in the 2014.11 release cycle. Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Reviewed-by: Samuel Martin <s.martin49@gmail.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Tested-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 5d84c4bf8d..0b6e597142 100644
--- a/Makefile
+++ b/Makefile
@@ -271,6 +271,8 @@ unexport DESTDIR
# Causes breakage with packages that needs host-ruby
unexport RUBYOPT
+include package/pkg-utils.mk
+
ifeq ($(BR2_HAVE_DOT_CONFIG),y)
################################################################################