aboutsummaryrefslogtreecommitdiff
path: root/configs/galileo_defconfig
diff options
context:
space:
mode:
authorGravatar Yann E. MORIN <yann.morin.1998@free.fr>2016-02-06 00:06:18 +0100
committerGravatar Thomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-02-06 10:59:15 +0100
commit674e09967818bf49fd1b6bf1f986a4c0f917fa63 (patch)
tree072e90a18d781e967a995bba79dc7d8b5070766e /configs/galileo_defconfig
parente3e0583f9085eff4cd6d58460f4d044e895d6775 (diff)
downloadbuildroot-674e09967818bf49fd1b6bf1f986a4c0f917fa63.tar.gz
buildroot-674e09967818bf49fd1b6bf1f986a4c0f917fa63.tar.bz2
defconfigs: all use the headers from the kernel
For most defconfigs, it was trivial to deduce the kernel version, by just reading the version string, which could be: - a standard upstream version string vX.Y.Z - a non-standard version string, but still containg the standard X.Y.Z Those for which it was not so trivial were those hosted on git tree. Since most were already using a custom linux-headers version, it could be easily deduced from that. It was confirmed by browsing said git trees and check the version there. There are a few cases were there was a mismatch: - microzed: uses a 3.18 kernel, but 3.8 headers; fixed. - xilinx_zc706: uses a 3.14 kernel, but 3.8 headers; fixed. - zedboard: uses a 3.18 kernel, but 3.8 headers; fixed. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Cc: Peter Korsgaard <peter@korsgaard.com> Cc: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'configs/galileo_defconfig')
-rw-r--r--configs/galileo_defconfig3
1 files changed, 1 insertions, 2 deletions
diff --git a/configs/galileo_defconfig b/configs/galileo_defconfig
index 95ddfc159c..ba8f62f177 100644
--- a/configs/galileo_defconfig
+++ b/configs/galileo_defconfig
@@ -1,6 +1,5 @@
BR2_x86_x1000=y
-BR2_KERNEL_HEADERS_VERSION=y
-BR2_DEFAULT_KERNEL_VERSION="3.8"
+# Linux headers same as kernel, a 3.8 series
BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_3_8=y
# Binutils 2.25 is required as this enables stripping the LOCK prefix
BR2_BINUTILS_VERSION_2_25_X=y