aboutsummaryrefslogtreecommitdiff
path: root/package/bandwidthd/bandwidthd.mk
diff options
context:
space:
mode:
authorGravatar Nathaniel Roach <nroach44@gmail.com>2014-08-15 08:27:09 +0800
committerGravatar Peter Korsgaard <peter@korsgaard.com>2014-08-15 11:05:44 +0200
commit8b3f257cd7dbc7e1c127fc8d25ac77a9e4e862c9 (patch)
tree9deac204910b6066ea26cbd943dde377bd370f2a /package/bandwidthd/bandwidthd.mk
parent12a3ecfc9a18a88a363ab72030c5afac3452adf9 (diff)
downloadbuildroot-8b3f257cd7dbc7e1c127fc8d25ac77a9e4e862c9.tar.gz
buildroot-8b3f257cd7dbc7e1c127fc8d25ac77a9e4e862c9.tar.bz2
bandwidthd: incorporate fixes for autobuilders
"The build failures of bandwidthd observed in the autobuilders in relation to libpng are caused by the usage of -L/usr/lib -L/usr/local/lib in the compiler flags, which leads the configure script to try to link against a host libpng library." These issues are fixed by: * Version bump to -r08 "[patched] the configure.ac script to remove the hardcoded -L/usr/local/lib and -I/usr/local/include. The bandwidthd package -was already autoreconfigured, so there is no need to add it." * "Adding the --without-x option, which ensures that the configure.ac script will not add -L/usr/lib to the compiler flags (and we anyway haven't added any sort of X.org support to bandwidthd for the moment)." Both fixes by Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/bandwidthd/bandwidthd.mk')
-rw-r--r--package/bandwidthd/bandwidthd.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/bandwidthd/bandwidthd.mk b/package/bandwidthd/bandwidthd.mk
index 9b1eb32ee7..3e11d6abb1 100644
--- a/package/bandwidthd/bandwidthd.mk
+++ b/package/bandwidthd/bandwidthd.mk
@@ -4,7 +4,7 @@
#
################################################################################
-BANDWIDTHD_VERSION = v2.0.1-auto-r07
+BANDWIDTHD_VERSION = v2.0.1-auto-r08
BANDWIDTHD_SITE = $(call github,nroach44,bandwidthd,$(BANDWIDTHD_VERSION))
# Specified as "any version of the GPL that is current as of your
@@ -15,6 +15,8 @@ BANDWIDTHD_DEPENDENCIES = gd libpng libpcap
BANDWIDTHD_AUTORECONF = YES
+BANDWIDTHD_CONF_OPT += --without-x
+
ifeq ($(BR2_PACKAGE_BANDWIDTHD_POSTGRESQL),y)
BANDWIDTHD_DEPENDENCIES += postgresql
BANDWIDTHD_CONF_OPT += --with-postgresql-logging=true