aboutsummaryrefslogtreecommitdiff
path: root/package/bluez5_utils
diff options
context:
space:
mode:
authorGravatar Thomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-08-14 20:28:34 +0200
committerGravatar Peter Korsgaard <peter@korsgaard.com>2014-08-15 10:18:23 +0200
commit1e9d40fc2396d823c21fa624651f3bd7c28f4b87 (patch)
tree8f63c4dd0272237666c39b7d530aeea996d206cc /package/bluez5_utils
parentcaa04a8cf7acb7682e79362bc2f5e9cd3c126bd2 (diff)
downloadbuildroot-1e9d40fc2396d823c21fa624651f3bd7c28f4b87.tar.gz
buildroot-1e9d40fc2396d823c21fa624651f3bd7c28f4b87.tar.bz2
bluez5_utils: gatttool depends on bluez5_utils client
The gatttool utility uses readline, and is therefore built only if --enable-client is used, i.e when bluez5_utils client applications are enabled. Therefore, this commit makes BR2_PACKAGE_BLUEZ5_UTILS_GATTTOOL depend on BR2_PACKAGE_BLUEZ5_UTILS_CLIENT. It also moves BR2_PACKAGE_BLUEZ5_UTILS_GATTTOOL to be right below the BR2_PACKAGE_BLUEZ5_UTILS_CLIENT definition. Fixes: http://autobuild.buildroot.org/results/f2b/f2b8b1bf5d50e6223a9a6d6858320975edb2a25a/ Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/bluez5_utils')
-rw-r--r--package/bluez5_utils/Config.in21
1 files changed, 11 insertions, 10 deletions
diff --git a/package/bluez5_utils/Config.in b/package/bluez5_utils/Config.in
index 10588db578..ec1352f720 100644
--- a/package/bluez5_utils/Config.in
+++ b/package/bluez5_utils/Config.in
@@ -39,18 +39,9 @@ config BR2_PACKAGE_BLUEZ5_UTILS_CLIENT
help
Enable the Bluez 5.x command line client.
-config BR2_PACKAGE_BLUEZ5_UTILS_EXPERIMENTAL
- bool "build experimental plugins"
- help
- Build BlueZ 5.x experimental plugins (SAP, NFC, ...).
-
-config BR2_PACKAGE_BLUEZ5_UTILS_TEST
- bool "build tests"
- help
- Build BlueZ 5.x tests
-
config BR2_PACKAGE_BLUEZ5_UTILS_GATTTOOL
bool "install GATT tool"
+ depends on BR2_PACKAGE_BLUEZ5_UTILS_CLIENT
help
Generic Attribute Profile (GATT) support. This provides
profile discovery and description services for Bluetooth Low
@@ -59,6 +50,16 @@ config BR2_PACKAGE_BLUEZ5_UTILS_GATTTOOL
It is always built with BlueZ 5.x, but upstream choose not
to install it by default.
+config BR2_PACKAGE_BLUEZ5_UTILS_EXPERIMENTAL
+ bool "build experimental plugins"
+ help
+ Build BlueZ 5.x experimental plugins (SAP, NFC, ...).
+
+config BR2_PACKAGE_BLUEZ5_UTILS_TEST
+ bool "build tests"
+ help
+ Build BlueZ 5.x tests
+
endif
comment "bluez5-utils needs a toolchain w/ wchar, threads, IPv6, headers >= 3.4"