aboutsummaryrefslogtreecommitdiff
path: root/package/bluez5_utils
diff options
context:
space:
mode:
authorGravatar Thomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-01-16 18:12:22 +0100
committerGravatar Thomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-01-16 18:12:22 +0100
commitd7c54cb0c0cf8cb013d88ad3c2989ec323323235 (patch)
tree1ea8aa9020dc35e58ed498c2dc5b6eaa7b167a68 /package/bluez5_utils
parentf9d6ba356109508108bf896a57521af30886685c (diff)
downloadbuildroot-d7c54cb0c0cf8cb013d88ad3c2989ec323323235.tar.gz
buildroot-d7c54cb0c0cf8cb013d88ad3c2989ec323323235.tar.bz2
bluez5_utils: not available with uClibc
Since the bump from 5.27 to 5.37 of bluez5_utils, the bluez code has started using <wordexp.h> functionality. Unfortunately, our current uClibc configuration does not have the wordexp functionality enabled, so bluez5_utils cannot be built anymore. In order to address this, we make bluez5_utils unavailable on uClibc. This could be changed later by either removing the dependency of bluez5_utils on wordexp support, or by deciding to add wordexp support to our uClibc configuration. Fixes: http://autobuild.buildroot.org/results/831/83112559d84dc156141339a31e3e02f1a2af5155/ Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/bluez5_utils')
-rw-r--r--package/bluez5_utils/Config.in7
1 files changed, 5 insertions, 2 deletions
diff --git a/package/bluez5_utils/Config.in b/package/bluez5_utils/Config.in
index 80c383030b..57f8c452a8 100644
--- a/package/bluez5_utils/Config.in
+++ b/package/bluez5_utils/Config.in
@@ -6,6 +6,8 @@ config BR2_PACKAGE_BLUEZ5_UTILS
depends on !BR2_STATIC_LIBS # uses dlfcn
depends on !BR2_PACKAGE_BLUEZ_UTILS # conflicts with 4.x version
depends on BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_4
+ # wordexp support not in our uClibc configuration
+ depends on !BR2_TOOLCHAIN_USES_UCLIBC
select BR2_PACKAGE_DBUS
select BR2_PACKAGE_LIBGLIB2
help
@@ -74,9 +76,10 @@ config BR2_PACKAGE_BLUEZ5_UTILS_TEST
endif
-comment "bluez5-utils needs a toolchain w/ wchar, threads, headers >= 3.4, dynamic library"
+comment "bluez5-utils needs a glibc or musl toolchain w/ wchar, threads, headers >= 3.4, dynamic library"
depends on !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS || \
- !BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_4 || BR2_STATIC_LIBS
+ !BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_4 || BR2_STATIC_LIBS || \
+ !(BR2_TOOLCHAIN_USES_GLIBC || BR2_TOOLCHAIN_USES_MUSL)
depends on BR2_USE_MMU
comment "bluez5-utils conflicts with older bluez-utils version"