aboutsummaryrefslogtreecommitdiff
path: root/package/duma
diff options
context:
space:
mode:
authorGravatar Jerzy Grzegorek <jerzy.grzegorek@trzebnica.net>2014-01-14 11:30:58 +0100
committerGravatar Peter Korsgaard <peter@korsgaard.com>2014-01-14 14:54:31 +0100
commitc4cc84afc60bbfa34b405ac1589a52087212fd84 (patch)
tree958b383fc07b22f035367ffa01e7d682e2611d0c /package/duma
parent4950bda10f1bf7468cec7c8af8dca6b20f36f6d4 (diff)
downloadbuildroot-c4cc84afc60bbfa34b405ac1589a52087212fd84.tar.gz
buildroot-c4cc84afc60bbfa34b405ac1589a52087212fd84.tar.bz2
package: unification of use $(subst [._-], [._-], $(<PKG>_VERSION)) macro
Currently, there are five packages which use 'subst' macro to change their version. * Three of them (ebtables, icu, perl) use this macro "in place" : EBTABLES_SITE = http://downloads.sourceforge.net/project/ebtables/ebtables/ebtables-$(subst .,-,$(EBTABLES_VERSION)) ICU_SOURCE = icu4c-$(subst .,_,$(ICU_VERSION))-src.tgz PERL_CROSS_OLD_POD = perl$(subst .,,$(PERL_CROSS_BASE_VERSION))delta.pod PERL_CROSS_NEW_POD = perl$(subst .,,$(PERL_VERSION))delta.pod * Two of them (boost, libnss) use an additional variable : BOOST_FILE_VERSION = $(subst .,_,$(BOOST_VERSION)) BOOST_SOURCE = boost_$(BOOST_FILE_VERSION).tar.bz2 LIBNSS_SITE_VERSION = $(subst .,_,$(LIBNSS_VERSION)) LIBNSS_SITE = https://ftp.mozilla.org/pub/mozilla.org/security/nss/releases/NSS_$(LIBNSS_SITE_VERSION)_RTM/src * Additionally two packages (duma, rings) doesn't use it at all : DUMA_VERSION = 2_5_15 DUMA_SITE = http://downloads.sourceforge.net/project/duma/duma/2.5.15 RINGS_VERSION_MAJOR = 1.3.0 RINGS_SUBDIR = rings-v_1_3_0 This commit makes changes to use 'subst' macro "in place", in all of them. Signed-off-by: Jerzy Grzegorek <jerzy.grzegorek@trzebnica.net> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/duma')
-rw-r--r--package/duma/duma.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/duma/duma.mk b/package/duma/duma.mk
index 93ae16e48e..d11987f4af 100644
--- a/package/duma/duma.mk
+++ b/package/duma/duma.mk
@@ -4,9 +4,9 @@
#
################################################################################
-DUMA_VERSION = 2_5_15
-DUMA_SOURCE = duma_$(DUMA_VERSION).tar.gz
-DUMA_SITE = http://downloads.sourceforge.net/project/duma/duma/2.5.15
+DUMA_VERSION = 2.5.15
+DUMA_SOURCE = duma_$(subst .,_,$(DUMA_VERSION)).tar.gz
+DUMA_SITE = http://downloads.sourceforge.net/project/duma/duma/$(DUMA_VERSION)
DUMA_LICENSE = GPLv2+ LGPLv2.1+
DUMA_LICENSE_FILES = COPYING-GPL COPYING-LGPL