aboutsummaryrefslogtreecommitdiff
path: root/package/ecryptfs-utils
diff options
context:
space:
mode:
authorGravatar Giulio Benetti <giulio.benetti@micronovasrl.com>2019-06-26 14:58:56 +0200
committerGravatar Thomas Petazzoni <thomas.petazzoni@bootlin.com>2019-08-03 12:57:45 +0200
commit862e47aec2ff8165c83d99f49639a1006be78ef2 (patch)
treeef856d9cbba28977abc4b6fae1b8cdc744bd6e13 /package/ecryptfs-utils
parent2716244b340a87186a8fd6e89cd7f18197ba3cdb (diff)
downloadbuildroot-862e47aec2ff8165c83d99f49639a1006be78ef2.tar.gz
buildroot-862e47aec2ff8165c83d99f49639a1006be78ef2.tar.bz2
package/ecryptfs-utils: remove libnss gcc bug dependency
Package libnss had a BR2_TOOLCHAIN_HAS_GCC_BUG_85862 dependency and since ecryptfs-utils depends on libnss it does have this dependnecy as well. However, gcc bug 85862 has been worked around now in libnss by disabling optimization, so libnss no longer has this BR2_TOOLCHAIN_HAS_GCC_BUG_85862 dependency. We can therefore drop it from ecryptfs-utils as well. Signed-off-by: Giulio Benetti <giulio.benetti@micronovasrl.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Diffstat (limited to 'package/ecryptfs-utils')
-rw-r--r--package/ecryptfs-utils/Config.in4
1 files changed, 0 insertions, 4 deletions
diff --git a/package/ecryptfs-utils/Config.in b/package/ecryptfs-utils/Config.in
index b589368a6a..68a659d33d 100644
--- a/package/ecryptfs-utils/Config.in
+++ b/package/ecryptfs-utils/Config.in
@@ -6,7 +6,6 @@ config BR2_PACKAGE_ECRYPTFS_UTILS
depends on BR2_PACKAGE_LIBNSPR_ARCH_SUPPORT # libnss -> libnspr
depends on !BR2_MIPS_NABI32 # libnss
depends on !BR2_STATIC_LIBS # libnss, keyutils
- depends on !BR2_TOOLCHAIN_HAS_GCC_BUG_85862 # microblaze specific & GCC < 7.x
select BR2_PACKAGE_KEYUTILS
select BR2_PACKAGE_LIBNSS
# runtime dependency only, some scripts are using the
@@ -34,6 +33,3 @@ comment "ecryptfs-utils needs a toolchain w/ threads, wchar, dynami library"
depends on BR2_USE_MMU
depends on !BR2_TOOLCHAIN_HAS_THREADS || !BR2_USE_WCHAR || \
BR2_STATIC_LIBS
-
-comment "ecryptfs needs a toolchain not affected by GCC bug 85862"
- depends on BR2_TOOLCHAIN_HAS_GCC_BUG_85862 # libnss