aboutsummaryrefslogtreecommitdiff
path: root/package/efivar
diff options
context:
space:
mode:
authorGravatar Erico Nunes <nunes.erico@gmail.com>2016-06-26 23:36:27 +0200
committerGravatar Thomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-07-01 16:31:29 +0200
commit481310c9ad65e1dd5b25986919d06473112e1b50 (patch)
tree6c78fe2fe865179bd52bd48b795c18c6c9169c19 /package/efivar
parentea22b78d4bb8779a17519dc81a4a7a0c05ad59e7 (diff)
downloadbuildroot-481310c9ad65e1dd5b25986919d06473112e1b50.tar.gz
buildroot-481310c9ad65e1dd5b25986919d06473112e1b50.tar.bz2
efivar: depends on target gcc >= 4.7
The efivar internal build system uses flags such as -std=gnu11 , -Wmaybe-uninitialized , -flto which are available in gcc >= 4.7 only. These flags are passed both to target build and to build a host tool. For the host part, this has been worked around by overriding 'gcc_flags', but doing that for the target would remove all flags that upstream intended for the target build. Buildroot doesn't support building gcc 4.6 in its own toolchain anymore but it's possible to use an external toolchain with gcc 4.6 which would be unable to build this package. This patch adds a limitation on toolchains with target gcc >= 4.7 to make sure that the flags are available in the chosen toolchain. Signed-off-by: Erico Nunes <nunes.erico@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/efivar')
-rw-r--r--package/efivar/Config.in6
1 files changed, 4 insertions, 2 deletions
diff --git a/package/efivar/Config.in b/package/efivar/Config.in
index 9cd1f1949e..5342fa4ba3 100644
--- a/package/efivar/Config.in
+++ b/package/efivar/Config.in
@@ -4,12 +4,14 @@ config BR2_PACKAGE_EFIVAR
# doesn't build with uclibc due to lack of uchar.h
# doesn't build with musl due to lack of __bswap_constant_16
depends on BR2_TOOLCHAIN_USES_GLIBC
+ depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_7
select BR2_PACKAGE_POPT
help
Tools and libraries to manipulate EFI variables
https://github.com/rhinstaller/efivar
-comment "efivar requires a glibc toolchain w/ headers >= 3.12"
+comment "efivar requires a glibc toolchain w/ headers >= 3.12, gcc >= 4.7"
depends on !BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_12 || \
- !BR2_TOOLCHAIN_USES_GLIBC
+ !BR2_TOOLCHAIN_USES_GLIBC || \
+ !BR2_TOOLCHAIN_GCC_AT_LEAST_4_7