aboutsummaryrefslogtreecommitdiff
path: root/package/elfutils/Config.in
diff options
context:
space:
mode:
authorGravatar Vicente Olivert Riera <Vincent.Riera@imgtec.com>2016-06-17 15:48:29 +0100
committerGravatar Thomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-06-18 14:59:39 +0200
commit794ae61a15f7a36e199b62b2e5224cfc41bdabea (patch)
tree992af3cb07841270d4da6f30390d3f236d4bab76 /package/elfutils/Config.in
parenta97dc46d7e7fcdf83020371d4ae3fe8d886d8aee (diff)
downloadbuildroot-794ae61a15f7a36e199b62b2e5224cfc41bdabea.tar.gz
buildroot-794ae61a15f7a36e199b62b2e5224cfc41bdabea.tar.bz2
elfutils: bump version to 0.166
- Remove 0001-argp-support.patch since it's already included upstream: https://git.fedorahosted.org/cgit/elfutils.git/commit/?id=1ab3c2befeedf5bd891cfbe17cfef79c06e5079a - Tweak patches for this new version: - 0002-disable-progs.patch - 0003-fts.patch - 0004-disable-po.patch - 0005-really-make-werror-conditional-to-build-werror.patch - Remove 0007-Allow-disabling-symbol-versioning-at-configure-t since it's already included upstream: https://git.fedorahosted.org/cgit/elfutils.git/commit/?id=bafacacaf7659a4933604662daba26a480b29a8d - Remove portability patch since it's no longer needed. I have asked Mark Wielaard regarding this topic given the portability patch looks been discontinued since 0.163 and he replied the following: - "I believe it is no longer needed. At least not on any platform I am actively maintaining. See also this discussion from last year: https://lists.fedorahosted.org/pipermail/elfutils-devel/2015-May/004825.html" - Add zlib dependency since it's now mandatory: configure: error: zlib not found but is required Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/elfutils/Config.in')
-rw-r--r--package/elfutils/Config.in1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/elfutils/Config.in b/package/elfutils/Config.in
index ca93770bfb..cbb5af2135 100644
--- a/package/elfutils/Config.in
+++ b/package/elfutils/Config.in
@@ -5,6 +5,7 @@ comment "elfutils needs a uClibc or (e)glibc toolchain w/ wchar, dynamic library
config BR2_PACKAGE_ELFUTILS
bool "elfutils"
+ select BR2_PACKAGE_ZLIB
select BR2_PACKAGE_ARGP_STANDALONE if BR2_TOOLCHAIN_USES_UCLIBC
select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT
depends on BR2_USE_WCHAR