aboutsummaryrefslogtreecommitdiff
path: root/package/elfutils
diff options
context:
space:
mode:
authorGravatar Thomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-06-30 21:29:09 +0200
committerGravatar Peter Korsgaard <jacmet@sunsite.dk>2013-07-04 09:08:42 +0200
commit381616e77ae7610f8fe07b9e0eb193d613fb3bf7 (patch)
tree515b70bd7c2d467ec903e0002f1766c17800b045 /package/elfutils
parent12d1aa4b69614f6499847758294f8a40f1611710 (diff)
downloadbuildroot-381616e77ae7610f8fe07b9e0eb193d613fb3bf7.tar.gz
buildroot-381616e77ae7610f8fe07b9e0eb193d613fb3bf7.tar.bz2
Introduce BR2_TOOLCHAIN_USES_{UCLIBC, GLIBC}
Currently, when we need to do a conditional on the type of C library used, we need to take into account the three toolchain backends. As we are going to add eglibc support to the Buildroot toolchain backend, it would become even uglier, so this patch introduces two new hidden options: BR2_TOOLCHAIN_USES_UCLIBC and BR2_TOOLCHAIN_USES_GLIBC, that exist regardless of the toolchain backend. The entire Buildroot code base is converted to use those options. Note that we have intentionally created only one option (BR2_TOOLCHAIN_USES_GLIBC) for both glibc and eglibc, since they are essentially the same, as far as Buildroot is concerned. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/elfutils')
-rw-r--r--package/elfutils/Config.in9
-rw-r--r--package/elfutils/elfutils.mk2
2 files changed, 3 insertions, 8 deletions
diff --git a/package/elfutils/Config.in b/package/elfutils/Config.in
index 914eec6e52..c6a2b84852 100644
--- a/package/elfutils/Config.in
+++ b/package/elfutils/Config.in
@@ -3,10 +3,7 @@ comment "elfutils requires a toolchain with LARGEFILE and WCHAR support"
config BR2_PACKAGE_ELFUTILS
bool "elfutils"
- select BR2_PACKAGE_ARGP_STANDALONE if \
- BR2_TOOLCHAIN_BUILDROOT || \
- BR2_TOOLCHAIN_CTNG_uClibc || \
- BR2_TOOLCHAIN_EXTERNAL_UCLIBC
+ select BR2_PACKAGE_ARGP_STANDALONE if BR2_TOOLCHAIN_USES_UCLIBC
select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT
depends on BR2_LARGEFILE
depends on BR2_USE_WCHAR
@@ -23,9 +20,7 @@ if BR2_PACKAGE_ELFUTILS
config BR2_PACKAGE_ELFUTILS_PROGS
bool "Install programs"
- depends on BR2_TOOLCHAIN_EXTERNAL_GLIBC || \
- BR2_TOOLCHAIN_CTNG_glibc || \
- BR2_TOOLCHAIN_CTNG_eglibc
+ depends on BR2_TOOLCHAIN_USES_GLIBC
help
This option tells elfutils to not only install the libelf
libraries, but also the elfutils programs.
diff --git a/package/elfutils/elfutils.mk b/package/elfutils/elfutils.mk
index 2658786604..696b5667a2 100644
--- a/package/elfutils/elfutils.mk
+++ b/package/elfutils/elfutils.mk
@@ -37,7 +37,7 @@ endif
ELFUTILS_CONF_ENV += \
LDFLAGS="$(ELFUTILS_LDFLAGS)"
-ifeq ($(BR2_TOOLCHAIN_BUILDROOT)$(BR2_TOOLCHAIN_EXTERNAL_UCLIBC)$(BR2_TOOLCHAIN_CTNG_uClibc),y)
+ifeq ($(BR2_TOOLCHAIN_USES_UCLIBC),y)
ELFUTILS_DEPENDENCIES += argp-standalone
endif