aboutsummaryrefslogtreecommitdiff
path: root/package/foomatic-filters
diff options
context:
space:
mode:
authorGravatar Gustavo Zacarias <gustavo@zacarias.com.ar>2015-03-06 10:39:24 -0300
committerGravatar Thomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-03-16 22:26:30 +0100
commit2d05afa42792193fa392c9f5417e8effc73d1e38 (patch)
tree9c03103791ac0749a66db78539d2a14ef4cdc978 /package/foomatic-filters
parent252e57cf16670e566b04a2d132b3ad199d0767f9 (diff)
downloadbuildroot-2d05afa42792193fa392c9f5417e8effc73d1e38.tar.gz
buildroot-2d05afa42792193fa392c9f5417e8effc73d1e38.tar.bz2
cups: deprecate package due to security issues
Also mark packages that depend on cups as deprecated as well for easier tracking. It would probably be better to mark it as a legacy option so users get a warning when migrating configuration files, but it would require a direct removal for that. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/foomatic-filters')
-rw-r--r--package/foomatic-filters/Config.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/foomatic-filters/Config.in b/package/foomatic-filters/Config.in
index 377566e929..0571eb9467 100644
--- a/package/foomatic-filters/Config.in
+++ b/package/foomatic-filters/Config.in
@@ -1,10 +1,14 @@
comment "foomatic-filters needs a toolchain w/ threads"
+ # because of cups security issues
+ depends on BR2_DEPRECATED_SINCE_2015_05
depends on BR2_PACKAGE_CUPS
depends on !BR2_TOOLCHAIN_HAS_THREADS
config BR2_PACKAGE_FOOMATIC_FILTERS
bool "foomatic_filters"
depends on BR2_PACKAGE_CUPS
+ # because of cups security issues
+ depends on BR2_DEPRECATED_SINCE_2015_05
depends on BR2_TOOLCHAIN_HAS_THREADS # libusb
select BR2_PACKAGE_LIBUSB
select BR2_PACKAGE_ENSCRIPT