aboutsummaryrefslogtreecommitdiff
path: root/package/gcc/Config.in.host
diff options
context:
space:
mode:
authorGravatar Andreas Larsson <andreas@gaisler.com>2014-10-30 09:29:36 +0100
committerGravatar Thomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-10-30 21:29:44 +0100
commit40e18f297600657111868df0c8c1fb7be55bc544 (patch)
tree89c5fe214ad5e1504e1da2ea9d2c4c5747008b5f /package/gcc/Config.in.host
parent43b78e7285e1d744c304b72a03fe1e9f2d2e047a (diff)
downloadbuildroot-40e18f297600657111868df0c8c1fb7be55bc544.tar.gz
buildroot-40e18f297600657111868df0c8c1fb7be55bc544.tar.bz2
gcc: remove version 4.4.x
That gcc series is old and is not used as the default version for any of the architectures we support, so this commit gets rid of it. [Thomas: move the Config.in.legacy option at the right location.] Signed-off-by: Andreas Larsson <andreas@gaisler.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/gcc/Config.in.host')
-rw-r--r--package/gcc/Config.in.host24
1 files changed, 0 insertions, 24 deletions
diff --git a/package/gcc/Config.in.host b/package/gcc/Config.in.host
index 07efac8057..de40c631ee 100644
--- a/package/gcc/Config.in.host
+++ b/package/gcc/Config.in.host
@@ -21,29 +21,6 @@ choice
# Only supported architecture
depends on BR2_avr32
- config BR2_GCC_VERSION_4_4_X
- bool "gcc 4.4.x"
- # Broken or unsupported architectures
- depends on !BR2_microblaze && !BR2_aarch64 && !BR2_arc \
- && !BR2_avr32 && !BR2_powerpc64le
- # Broken or unsupported ARM cores
- depends on !BR2_cortex_a5 && !BR2_cortex_a7 && \
- !BR2_cortex_a12 && !BR2_cortex_a15 && !BR2_fa526 && \
- !BR2_pj4
- # SPARC -mcpu=leon3 appeared in gcc 4.8.3
- depends on !BR2_sparc_leon3
- # ARM EABIhf support appeared in gcc 4.6
- depends on !BR2_ARM_EABIHF
- # ARM VFPv4 support appeared in gcc 4.5
- depends on !BR2_ARM_FPU_VFPV4 && !BR2_ARM_FPU_VFPV4D16
- # Broken or unsupported PPC cores
- depends on !BR2_powerpc_476 && !BR2_powerpc_476fp \
- && !BR2_power8
- # Broken or unsupported x86 cores
- depends on !BR2_x86_atom && !BR2_x86_corei7 && !BR2_x86_jaguar
- # musl patches only for gcc 4.7+
- depends on !BR2_TOOLCHAIN_BUILDROOT_MUSL
-
config BR2_GCC_VERSION_4_5_X
bool "gcc 4.5.x"
# Broken or unsupported architectures
@@ -114,7 +91,6 @@ config BR2_GCC_SUPPORTS_FINEGRAINEDMTUNE
config BR2_GCC_VERSION
string
default "4.2.2-avr32-2.1.5" if BR2_GCC_VERSION_4_2_2_AVR32_2_1_5
- default "4.4.7" if BR2_GCC_VERSION_4_4_X
default "4.5.4" if BR2_GCC_VERSION_4_5_X
default "4.7.4" if BR2_GCC_VERSION_4_7_X
default "4.8.3" if BR2_GCC_VERSION_4_8_X