aboutsummaryrefslogtreecommitdiff
path: root/package/gob2
diff options
context:
space:
mode:
authorGravatar Gustavo Zacarias <gustavo@zacarias.com.ar>2015-01-15 11:30:18 -0300
committerGravatar Peter Korsgaard <peter@korsgaard.com>2015-01-26 00:02:58 +0100
commit7f9d4441159836b1a3ba9b214f318943bbda4b44 (patch)
treed8a79476273d1bbcb080e256ab40e2c8ce416229 /package/gob2
parentc2e3d0be90409ec53e2c02f8ece0d62d04999fb0 (diff)
downloadbuildroot-7f9d4441159836b1a3ba9b214f318943bbda4b44.tar.gz
buildroot-7f9d4441159836b1a3ba9b214f318943bbda4b44.tar.bz2
gob2: remove deprecated target package
It's been deprecated for a year now so remove the target variant. Also rename patch to new naming convention. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/gob2')
-rw-r--r--package/gob2/0001-dont-include-from-prefix.patch (renamed from package/gob2/gob2-01-dont-include-from-prefix.patch)0
-rw-r--r--package/gob2/Config.in20
-rw-r--r--package/gob2/gob2.mk2
3 files changed, 0 insertions, 22 deletions
diff --git a/package/gob2/gob2-01-dont-include-from-prefix.patch b/package/gob2/0001-dont-include-from-prefix.patch
index 1b603d754f..1b603d754f 100644
--- a/package/gob2/gob2-01-dont-include-from-prefix.patch
+++ b/package/gob2/0001-dont-include-from-prefix.patch
diff --git a/package/gob2/Config.in b/package/gob2/Config.in
deleted file mode 100644
index bd9ba1f260..0000000000
--- a/package/gob2/Config.in
+++ /dev/null
@@ -1,20 +0,0 @@
-config BR2_PACKAGE_GOB2
- bool "gob2"
- depends on BR2_USE_WCHAR # glib2
- depends on BR2_TOOLCHAIN_HAS_THREADS # glib2
- depends on BR2_USE_MMU # bison, glib2
- select BR2_PACKAGE_LIBGLIB2
- select BR2_PACKAGE_FLEX
- select BR2_PACKAGE_BISON
- # development tool, useless on the target
- depends on BR2_DEPRECATED_SINCE_2014_02
- help
- GOB (GTK+ Object Builder) is a preprocessor which simplifies
- the writing of GObjects in C.
-
- http://www.jirka.org/gob.html
-
-comment "gob2 needs a toolchain w/ wchar"
- depends on BR2_USE_MMU
- depends on BR2_DEPRECATED_SINCE_2014_02
- depends on !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/gob2/gob2.mk b/package/gob2/gob2.mk
index e4f1396c98..04d02e115c 100644
--- a/package/gob2/gob2.mk
+++ b/package/gob2/gob2.mk
@@ -7,10 +7,8 @@
GOB2_VERSION = 2.0.20
GOB2_SOURCE = gob2-$(GOB2_VERSION).tar.xz
GOB2_SITE = http://ftp.5z.com/pub/gob
-GOB2_DEPENDENCIES = libglib2 flex bison host-pkgconf host-flex
HOST_GOB2_DEPENDENCIES = host-bison host-flex host-libglib2
-$(eval $(autotools-package))
$(eval $(host-autotools-package))
# gob2 for the host