aboutsummaryrefslogtreecommitdiff
path: root/package/gstreamer
diff options
context:
space:
mode:
authorGravatar Peter Seiderer <ps.report@gmx.net>2019-03-09 22:32:35 +0100
committerGravatar Thomas Petazzoni <thomas.petazzoni@bootlin.com>2019-03-12 23:09:32 +0100
commit8729c4ef881b02ff85b7645b0ad309d6ae44fccf (patch)
tree8607892b2803e181b03db62633091301f4fad083 /package/gstreamer
parent9524384192ea42dbfcc3ff84c63b574d91870510 (diff)
downloadbuildroot-8729c4ef881b02ff85b7645b0ad309d6ae44fccf.tar.gz
buildroot-8729c4ef881b02ff85b7645b0ad309d6ae44fccf.tar.bz2
package/zbar: bump version to 0.22
- change from git download to official release and download site (drop need for autoreconf) - drop dependency on kernel headers >= 3.17 (should be fixed with commit 'v4l2: make ZBar build and run on Kernels < 3.16' (see [1]), fall back to original kernel headers >= 3.0 dependency propagated from libv4l [1] https://git.linuxtv.org/zbar.git/commit/?id=fa5c48127ec1e3670e28540c2e6a03431ebac5b8 Signed-off-by: Peter Seiderer <ps.report@gmx.net> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Diffstat (limited to 'package/gstreamer')
-rw-r--r--package/gstreamer/gst-plugins-bad/Config.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/gstreamer/gst-plugins-bad/Config.in b/package/gstreamer/gst-plugins-bad/Config.in
index 411e4b6174..982edc2e4c 100644
--- a/package/gstreamer/gst-plugins-bad/Config.in
+++ b/package/gstreamer/gst-plugins-bad/Config.in
@@ -321,12 +321,12 @@ config BR2_PACKAGE_GST_PLUGINS_BAD_ZBAR
depends on BR2_TOOLCHAIN_HAS_THREADS # zbar-> libv4l
depends on BR2_USE_MMU # zbar-> libv4l
depends on BR2_INSTALL_LIBSTDCPP # zbar-> libv4l
- depends on BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_17 # zbar
+ depends on BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_0 # zbar -> libv4l
select BR2_PACKAGE_ZBAR
-comment "zbar plugin needs a toolchain w/ threads, C++ and headers >= 3.17"
+comment "zbar plugin needs a toolchain w/ threads, C++ and headers >= 3.0"
depends on BR2_USE_MMU
depends on !BR2_TOOLCHAIN_HAS_THREADS \
- || !BR2_INSTALL_LIBSTDCPP || !BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_17
+ || !BR2_INSTALL_LIBSTDCPP || !BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_0
endif