aboutsummaryrefslogtreecommitdiff
path: root/package/gstreamer
diff options
context:
space:
mode:
authorGravatar Fabrice Fontaine <fontaine.fabrice@gmail.com>2019-03-05 23:01:04 +0100
committerGravatar Thomas Petazzoni <thomas.petazzoni@bootlin.com>2019-03-07 22:32:18 +0100
commitc8421565b1c4c5edd94d0c65e4fad5cbcfd46e10 (patch)
tree604effd07b52db53c5ac6d96f8fcd2c04486d67b /package/gstreamer
parentaa02c6553ce6528ad0513f3e92264a28bcfa844d (diff)
downloadbuildroot-c8421565b1c4c5edd94d0c65e4fad5cbcfd46e10.tar.gz
buildroot-c8421565b1c4c5edd94d0c65e4fad5cbcfd46e10.tar.bz2
package/gst-plugins-bad: remove apexsink support
apexsink does not build with OpenSSL 1.1.x so remove this option especially because there is no more apexsink option in gstreamer1 (since version 1.12) Fixes: - http://autobuild.buildroot.org/results/a29e8a8509190fc4b3c419dae2301cf72a601f62 Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Diffstat (limited to 'package/gstreamer')
-rw-r--r--package/gstreamer/gst-plugins-bad/Config.in4
-rw-r--r--package/gstreamer/gst-plugins-bad/gst-plugins-bad.mk8
2 files changed, 1 insertions, 11 deletions
diff --git a/package/gstreamer/gst-plugins-bad/Config.in b/package/gstreamer/gst-plugins-bad/Config.in
index fe8457f6d2..411e4b6174 100644
--- a/package/gstreamer/gst-plugins-bad/Config.in
+++ b/package/gstreamer/gst-plugins-bad/Config.in
@@ -242,10 +242,6 @@ config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_Y4M
comment "plugins with external dependencies (there may be more available)"
-config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_APEXSINK
- bool "apexsink"
- select BR2_PACKAGE_OPENSSL
-
config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_BZ2
bool "bz2"
select BR2_PACKAGE_BZIP2
diff --git a/package/gstreamer/gst-plugins-bad/gst-plugins-bad.mk b/package/gstreamer/gst-plugins-bad/gst-plugins-bad.mk
index 856ff9665d..a98eac4235 100644
--- a/package/gstreamer/gst-plugins-bad/gst-plugins-bad.mk
+++ b/package/gstreamer/gst-plugins-bad/gst-plugins-bad.mk
@@ -12,6 +12,7 @@ GST_PLUGINS_BAD_LICENSE = LGPL-2.1+, GPL-2.0+
GST_PLUGINS_BAD_LICENSE_FILES = COPYING.LIB COPYING
GST_PLUGINS_BAD_CONF_OPTS = \
+ --disable-apexsink \
--disable-examples \
--disable-spandsp
@@ -472,13 +473,6 @@ GST_PLUGINS_BAD_CONF_OPTS += --disable-y4m
endif
# plugins with deps
-ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_APEXSINK),y)
-GST_PLUGINS_BAD_CONF_OPTS += --enable-apexsink
-GST_PLUGINS_BAD_DEPENDENCIES += openssl
-else
-GST_PLUGINS_BAD_CONF_OPTS += --disable-apexsink
-endif
-
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_BZ2),y)
GST_PLUGINS_BAD_CONF_OPTS += --enable-bz2
GST_PLUGINS_BAD_DEPENDENCIES += bzip2