aboutsummaryrefslogtreecommitdiff
path: root/package/gstreamer
diff options
context:
space:
mode:
authorGravatar Matt Weber <matthew.weber@rockwellcollins.com>2018-05-28 10:35:10 -0500
committerGravatar Thomas Petazzoni <thomas.petazzoni@bootlin.com>2018-05-30 23:23:21 +0200
commitfd97bc80c5b87a2e76e535c1b200fab9276446fc (patch)
tree8dc5914cb99aae857ac679a3b4337f0d2712d18c /package/gstreamer
parent30d52c67a77931495a51e9a27b98ec67a96cde54 (diff)
downloadbuildroot-fd97bc80c5b87a2e76e535c1b200fab9276446fc.tar.gz
buildroot-fd97bc80c5b87a2e76e535c1b200fab9276446fc.tar.bz2
toolchain: allow disabling packages affected by gcc bug 85180
Works around https://gcc.gnu.org/bugzilla/show_bug.cgi?id=85180 which is an issue where the Microblaze architecture had code that caused a infinite recursion while optimizing in versions of GCC earlier than 8.x. More BR discussion can be found on this thread. http://buildroot-busybox.2317881.n4.nabble.com/autobuild-buildroot-net-Build-results-for-2018-04-25-td192721.html Resolves: http://autobuild.buildroot.net/results/b42d68c66d8ea035845a28c5530ef0682fd95713 (boost) http://autobuild.buildroot.net/results/af976a4805fb8b3f0c17a8e3a1f901b2255caa0b (flare-engine) http://autobuild.buildroot.net/results/d20/d20700bd538ba1e9d45ab8a61ecbbba1a320ef38 (gst-ffmpeg) CC: Romain Naour <romain.naour@gmail.com> Signed-off-by: Matthew Weber <matthew.weber@rockwellcollins.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Diffstat (limited to 'package/gstreamer')
-rw-r--r--package/gstreamer/gst-ffmpeg/Config.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/gstreamer/gst-ffmpeg/Config.in b/package/gstreamer/gst-ffmpeg/Config.in
index 32bfdd53c6..1e95d016f6 100644
--- a/package/gstreamer/gst-ffmpeg/Config.in
+++ b/package/gstreamer/gst-ffmpeg/Config.in
@@ -5,6 +5,7 @@ config BR2_PACKAGE_GST_FFMPEG
depends on !BR2_MIPS_CPU_MIPS32R6 && !BR2_MIPS_CPU_MIPS64R6
# triggers https://gcc.gnu.org/bugzilla/show_bug.cgi?id=65151 on sh
depends on BR2_TOOLCHAIN_GCC_AT_LEAST_5 || !BR2_sh
+ depends on !BR2_TOOLCHAIN_HAS_GCC_BUG_85180
select BR2_PACKAGE_GST_PLUGINS_BASE
help
GStreamer plugin containing one plugin with a set of
@@ -28,3 +29,6 @@ endif
comment "gst-ffmpeg needs a toolchain w/ gcc >= 5"
depends on !BR2_TOOLCHAIN_GCC_AT_LEAST_5 && BR2_sh
+
+comment "gst-ffmpeg needs a toolchain not affected by GCC bug 85180"
+ depends on BR2_TOOLCHAIN_HAS_GCC_BUG_85180