aboutsummaryrefslogtreecommitdiff
path: root/package/ifupdown
diff options
context:
space:
mode:
authorGravatar Gustavo Zacarias <gustavo@zacarias.com.ar>2015-07-28 11:14:22 -0300
committerGravatar Thomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-07-28 22:56:09 +0200
commit869af2ad3de46c79677699f007a5ee942aa0bb3d (patch)
treec35e3c2b842d422692c32b83b7e11479ecd8257b /package/ifupdown
parent4a484792066222550a2c5c6ba41f7b7e4a391031 (diff)
downloadbuildroot-869af2ad3de46c79677699f007a5ee942aa0bb3d.tar.gz
buildroot-869af2ad3de46c79677699f007a5ee942aa0bb3d.tar.bz2
iproute2: needs headers >= 3.0
The newest iproute2 version requires a toolchain with headers >= 3.0 for proper namespace & bpf support, so adjust the dependencies and dependants accordingly. Fixes: http://autobuild.buildroot.net/results/fa8/fa810f310c7540e02c0ed84c4a3ce74ab602daa5/ Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/ifupdown')
-rw-r--r--package/ifupdown/Config.in6
1 files changed, 4 insertions, 2 deletions
diff --git a/package/ifupdown/Config.in b/package/ifupdown/Config.in
index 10cf2be115..1e11e4ee0a 100644
--- a/package/ifupdown/Config.in
+++ b/package/ifupdown/Config.in
@@ -1,6 +1,7 @@
config BR2_PACKAGE_IFUPDOWN
bool "ifupdown"
depends on BR2_USE_MMU # fork()
+ depends on BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_0 # iproute2
# Default/our uclibc lacks wordexp()
depends on !BR2_TOOLCHAIN_USES_UCLIBC
# runtime for ip binary
@@ -12,6 +13,7 @@ config BR2_PACKAGE_IFUPDOWN
https://tracker.debian.org/pkg/ifupdown
-comment "ifupdown needs an (e)glibc or musl toolchain"
+comment "ifupdown needs an (e)glibc or musl toolchain w/ headers >= 3.0"
depends on BR2_USE_MMU
- depends on BR2_TOOLCHAIN_USES_UCLIBC
+ depends on BR2_TOOLCHAIN_USES_UCLIBC || \
+ !BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_0