aboutsummaryrefslogtreecommitdiff
path: root/package/kodi-visualisation-goom
diff options
context:
space:
mode:
authorGravatar Bernd Kuhls <bernd.kuhls@t-online.de>2016-05-10 20:40:23 +0200
committerGravatar Thomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-05-11 16:14:20 +0200
commit71664e775c5e6632d0f103c7bd06e3e1d964c9ff (patch)
tree67b18e1b9e20c8f3f08c19927bd6b4414ffd6d6b /package/kodi-visualisation-goom
parent25ab35697e497810be92724eb84e0af4c49f6436 (diff)
downloadbuildroot-71664e775c5e6632d0f103c7bd06e3e1d964c9ff.tar.gz
buildroot-71664e775c5e6632d0f103c7bd06e3e1d964c9ff.tar.bz2
package/kodi-screensaver/visualisation-*: allow OpenGL build on arm
Kodi depends on egl/gles on arm, our Kconfig option BR2_PACKAGE_KODI_GL reflects this, it depends on !BR2_arm. This option is wrongly used in many Kodi addons needing OpenGL, they can be compiled even if Kodi itself uses egl/gles. This patch changes the dependency on BR2_PACKAGE_KODI_GL to BR2_PACKAGE_HAS_LIBGL. Tested using this defconfig: BR2_arm=y BR2_cortex_a17=y BR2_TOOLCHAIN_BUILDROOT_INET_RPC=y BR2_TOOLCHAIN_BUILDROOT_LOCALE=y BR2_TOOLCHAIN_BUILDROOT_CXX=y BR2_ROOTFS_DEVICE_CREATION_DYNAMIC_EUDEV=y BR2_PACKAGE_KODI=y BR2_PACKAGE_KODI_SCREENSAVER_ASTEROIDS=y BR2_PACKAGE_KODI_SCREENSAVER_ASTERWAVE=y BR2_PACKAGE_KODI_SCREENSAVER_BIOGENESIS=y BR2_PACKAGE_KODI_SCREENSAVER_CPBLOBS=y BR2_PACKAGE_KODI_SCREENSAVER_CRYSTALMORPH=y BR2_PACKAGE_KODI_SCREENSAVER_GREYNETIC=y BR2_PACKAGE_KODI_SCREENSAVER_MATRIXTRAILS=y BR2_PACKAGE_KODI_SCREENSAVER_PINGPONG=y BR2_PACKAGE_KODI_SCREENSAVER_PLANESTATE=y BR2_PACKAGE_KODI_SCREENSAVER_PYRO=y BR2_PACKAGE_KODI_SCREENSAVER_RSXS=y BR2_PACKAGE_KODI_SCREENSAVER_STARS=y BR2_PACKAGE_KODI_VISUALISATION_FISHBMC=y BR2_PACKAGE_KODI_VISUALISATION_FOUNTAIN=y BR2_PACKAGE_KODI_VISUALISATION_GOOM=y BR2_PACKAGE_KODI_VISUALISATION_SHADERTOY=y BR2_PACKAGE_KODI_VISUALISATION_SPECTRUM=y BR2_PACKAGE_KODI_VISUALISATION_WAVEFORHUE=y BR2_PACKAGE_KODI_VISUALISATION_WAVEFORM=y BR2_PACKAGE_MESA3D=y BR2_PACKAGE_MESA3D_DRI_DRIVER_SWRAST=y BR2_PACKAGE_MESA3D_OPENGL_EGL=y BR2_PACKAGE_MESA3D_OPENGL_ES=y BR2_PACKAGE_XORG7=y $ grep PACKAGE_HAS_LIB .config BR2_PACKAGE_HAS_LIBGL=y BR2_PACKAGE_HAS_LIBEGL=y BR2_PACKAGE_HAS_LIBGLES=y Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/kodi-visualisation-goom')
-rw-r--r--package/kodi-visualisation-goom/Config.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/kodi-visualisation-goom/Config.in b/package/kodi-visualisation-goom/Config.in
index 8577e61a04..de4d2ef2ff 100644
--- a/package/kodi-visualisation-goom/Config.in
+++ b/package/kodi-visualisation-goom/Config.in
@@ -1,10 +1,10 @@
config BR2_PACKAGE_KODI_VISUALISATION_GOOM
bool "kodi-visualisation-goom"
- depends on BR2_PACKAGE_KODI_GL
+ depends on BR2_PACKAGE_HAS_LIBGL
help
GOOM visualiser for Kodi
https://github.com/notspiff/visualization.goom
comment "kodi-visualization-goom needs OpenGL"
- depends on !BR2_PACKAGE_KODI_GL
+ depends on !BR2_PACKAGE_HAS_LIBGL