aboutsummaryrefslogtreecommitdiff
path: root/package/libcroco
diff options
context:
space:
mode:
authorGravatar Gustavo Zacarias <gustavo@zacarias.com.ar>2015-12-14 08:14:48 -0300
committerGravatar Thomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-12-15 22:36:24 +0100
commit52d7c9b9d131051a8f420fddd3f9661c28270870 (patch)
treeb9e8ec6da8e3050602a94f9e332bcde7249e79a8 /package/libcroco
parent3d5f55867a0c310bd8f268bdba19d986f5e3fc34 (diff)
downloadbuildroot-52d7c9b9d131051a8f420fddd3f9661c28270870.tar.gz
buildroot-52d7c9b9d131051a8f420fddd3f9661c28270870.tar.bz2
libcroco: new package
It's required for the librsvg upgrade (ditto host variant). Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/libcroco')
-rw-r--r--package/libcroco/Config.in20
-rw-r--r--package/libcroco/libcroco.hash2
-rw-r--r--package/libcroco/libcroco.mk20
3 files changed, 42 insertions, 0 deletions
diff --git a/package/libcroco/Config.in b/package/libcroco/Config.in
new file mode 100644
index 0000000000..5baf83dfb9
--- /dev/null
+++ b/package/libcroco/Config.in
@@ -0,0 +1,20 @@
+config BR2_PACKAGE_LIBCROCO
+ bool "libcroco"
+ select BR2_PACKAGE_LIBXML2
+ select BR2_PACKAGE_LIBGLIB2
+ depends on BR2_USE_WCHAR # glib2
+ depends on BR2_TOOLCHAIN_HAS_THREADS # glib2
+ depends on BR2_USE_MMU # glib2
+ help
+ Libcroco is a standalone css2 parsing and manipulation
+ library. The parser provides a low level event driven SAC
+ like api and a css object model like api.
+
+ Libcroco provides a CSS2 selection engine and an
+ experimental xml/css rendering engine.
+
+ https://github.com/GNOME/libcroco
+
+comment "libcroco needs a toolchain w/ wchar, threads"
+ depends on BR2_USE_MMU
+ depends on !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/libcroco/libcroco.hash b/package/libcroco/libcroco.hash
new file mode 100644
index 0000000000..20328e44a7
--- /dev/null
+++ b/package/libcroco/libcroco.hash
@@ -0,0 +1,2 @@
+# From http://ftp.acc.umu.se/pub/gnome/sources/libcroco/0.6/libcroco-0.6.10.sha256sum
+sha256 72066611df77f5c4fb28268cfc7306ecc1517212a6182c2ea756c326a154246c libcroco-0.6.10.tar.xz
diff --git a/package/libcroco/libcroco.mk b/package/libcroco/libcroco.mk
new file mode 100644
index 0000000000..2376684d09
--- /dev/null
+++ b/package/libcroco/libcroco.mk
@@ -0,0 +1,20 @@
+################################################################################
+#
+# libcroco
+#
+################################################################################
+
+LIBCROCO_VERSION_MAJOR = 0.6
+LIBCROCO_VERSION = $(LIBCROCO_VERSION_MAJOR).10
+LIBCROCO_SITE = http://ftp.gnome.org/pub/gnome/sources/libcroco/$(LIBCROCO_VERSION_MAJOR)
+LIBCROCO_SOURCE = libcroco-$(LIBCROCO_VERSION).tar.xz
+LIBCROCO_INSTALL_STAGING = YES
+LIBCROCO_DEPENDENCIES = host-pkgconf libglib2 libxml2
+LIBCROCO_CONFIG_SCRIPTS = croco-$(LIBCROCO_VERSION_MAJOR)-config
+# NEWS states that it's only LGPL
+# Source code says v2.1+ even though COPYING.LIB is v2
+LIBCROCO_LICENSE = LGPLv2.1+
+LIBCROSO_LICENSE_FILES = COPYING.LIB
+
+$(eval $(autotools-package))
+$(eval $(host-autotools-package))