aboutsummaryrefslogtreecommitdiff
path: root/package/libgtk2
diff options
context:
space:
mode:
authorGravatar Adam Duskett <Aduskett@gmail.com>2017-04-22 13:17:58 -0400
committerGravatar Thomas Petazzoni <thomas.petazzoni@free-electrons.com>2017-05-01 11:51:23 +0200
commit190b2b409ccf1ccf6b1f701d3d2a033c747ac013 (patch)
tree5acb334a6575aec4c2222c30218cfe2efc0dc9eb /package/libgtk2
parent6acd0a542e2d3aef2b65d3cabcb43561a9a8e8e2 (diff)
downloadbuildroot-190b2b409ccf1ccf6b1f701d3d2a033c747ac013.tar.gz
buildroot-190b2b409ccf1ccf6b1f701d3d2a033c747ac013.tar.bz2
package/l*/Config.in: fix ordering of statements
The check-package script when ran gives warnings on ordering issues on all of these Config files. This patch cleans up all warnings related to the ordering in the Config files for packages starting with the letter l in the package directory. The appropriate ordering is: type, default, depends on, select, help See http://nightly.buildroot.org/#_config_files for more information. Signed-off-by: Adam Duskett <Adamduskett@outlook.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/libgtk2')
-rw-r--r--package/libgtk2/Config.in12
1 files changed, 6 insertions, 6 deletions
diff --git a/package/libgtk2/Config.in b/package/libgtk2/Config.in
index b6cf37e191..aa297d71ef 100644
--- a/package/libgtk2/Config.in
+++ b/package/libgtk2/Config.in
@@ -1,5 +1,11 @@
config BR2_PACKAGE_LIBGTK2
bool "libgtk2"
+ depends on BR2_PACKAGE_XORG7
+ depends on BR2_USE_WCHAR # glib2
+ depends on BR2_TOOLCHAIN_HAS_THREADS # glib2
+ depends on BR2_USE_MMU # glib2
+ depends on BR2_INSTALL_LIBSTDCPP # pango
+ depends on BR2_TOOLCHAIN_HAS_SYNC_4 # pango -> harfbuzz
select BR2_PACKAGE_ATK
select BR2_PACKAGE_CAIRO
select BR2_PACKAGE_CAIRO_PS
@@ -12,12 +18,6 @@ config BR2_PACKAGE_LIBGTK2
select BR2_PACKAGE_XLIB_LIBX11
select BR2_PACKAGE_XLIB_LIBXEXT
select BR2_PACKAGE_XLIB_LIBXRENDER
- depends on BR2_PACKAGE_XORG7
- depends on BR2_USE_WCHAR # glib2
- depends on BR2_TOOLCHAIN_HAS_THREADS # glib2
- depends on BR2_USE_MMU # glib2
- depends on BR2_INSTALL_LIBSTDCPP # pango
- depends on BR2_TOOLCHAIN_HAS_SYNC_4 # pango -> harfbuzz
help
The GTK+ version 2 graphical user interface library