aboutsummaryrefslogtreecommitdiff
path: root/package/libmbim
diff options
context:
space:
mode:
authorGravatar Yegor Yefremov <yegorslists@googlemail.com>2015-12-02 12:27:06 +0100
committerGravatar Peter Korsgaard <peter@korsgaard.com>2015-12-08 21:49:10 +0100
commite739dd5a11f5b2bd9648a45623bc174adae42b6e (patch)
tree017fe08b73932c14a8c9e8546329fe3374b66989 /package/libmbim
parent6cfa5de33e71b46e9ae668550dc77aacabbde663 (diff)
downloadbuildroot-e739dd5a11f5b2bd9648a45623bc174adae42b6e.tar.gz
buildroot-e739dd5a11f5b2bd9648a45623bc174adae42b6e.tar.bz2
Use libgudev as regular dependency
Since eudev 3.1.3 libgudev is not shipped with this package, so libgudev can be used as regular dependency regardless of udev implementation selected. Fixes following build error: http://autobuild.buildroot.net/results/320/320c052bda0f1b5afb1e5c83a7fb4dca6227c5a1// http://autobuild.buildroot.net/results/3b0/3b096f882030325b9290ad8860bd9cd373a11dc2// Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com> Tested-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Reviewed-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Tested-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/libmbim')
-rw-r--r--package/libmbim/Config.in2
-rw-r--r--package/libmbim/libmbim.mk6
2 files changed, 2 insertions, 6 deletions
diff --git a/package/libmbim/Config.in b/package/libmbim/Config.in
index e79d51f3a9..0ef28db125 100644
--- a/package/libmbim/Config.in
+++ b/package/libmbim/Config.in
@@ -3,7 +3,7 @@ config BR2_PACKAGE_LIBMBIM
depends on BR2_USE_WCHAR # libglib2
depends on BR2_TOOLCHAIN_HAS_THREADS # libglib2
depends on BR2_PACKAGE_HAS_UDEV
- select BR2_PACKAGE_LIBGUDEV if BR2_INIT_SYSTEMD
+ select BR2_PACKAGE_LIBGUDEV
select BR2_PACKAGE_LIBGLIB2
help
libmbim is a glib-based library for talking to WWAN modems and
diff --git a/package/libmbim/libmbim.mk b/package/libmbim/libmbim.mk
index cb6c9055cc..3cb9235ecf 100644
--- a/package/libmbim/libmbim.mk
+++ b/package/libmbim/libmbim.mk
@@ -11,11 +11,7 @@ LIBMBIM_LICENSE = LGPLv2+ (library), GPLv2+ (programs)
LIBMBIM_LICENSE_FILES = COPYING
LIBMBIM_INSTALL_STAGING = YES
-LIBMBIM_DEPENDENCIES = libglib2 udev
-
-ifeq ($(BR2_PACKAGE_LIBGUDEV),y)
-LIBMBIM_DEPENDENCIES += libgudev
-endif
+LIBMBIM_DEPENDENCIES = libglib2 udev libgudev
# we don't want -Werror
LIBMBIM_CONF_OPTS = --enable-more-warnings=no