aboutsummaryrefslogtreecommitdiff
path: root/package/libplayer
diff options
context:
space:
mode:
authorGravatar Arnout Vandecappelle <arnout@mind.be>2017-03-08 00:50:52 +0100
committerGravatar Thomas Petazzoni <thomas.petazzoni@free-electrons.com>2017-03-09 22:28:38 +0100
commit0f5b3d0fd8199332beb5032d6838ccb64f8786ab (patch)
tree51d1b49d0732d1ba124fc93b5475c49c87a22111 /package/libplayer
parenta603f03f11ef6facd5006cd241696beaad3f1689 (diff)
downloadbuildroot-0f5b3d0fd8199332beb5032d6838ccb64f8786ab.tar.gz
buildroot-0f5b3d0fd8199332beb5032d6838ccb64f8786ab.tar.bz2
libplayer: remove broken Python bindings
This option has been marked as broken since 2011. No need for legacy handling. And anyway, nowadays we use automatic dependencies for bindings. Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/libplayer')
-rw-r--r--package/libplayer/Config.in6
-rw-r--r--package/libplayer/libplayer.mk5
2 files changed, 0 insertions, 11 deletions
diff --git a/package/libplayer/Config.in b/package/libplayer/Config.in
index 37fbb26c5b..89809ebcfa 100644
--- a/package/libplayer/Config.in
+++ b/package/libplayer/Config.in
@@ -26,11 +26,5 @@ comment "gstreamer backend needs a toolchain w/ wchar, threads"
depends on BR2_USE_MMU
depends on !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS
-config BR2_PACKAGE_LIBPLAYER_PYTHON
- depends on BR2_PACKAGE_PYTHON
- depends on BROKEN # player_init params, builds for host
- bool "Libplayer python bindings"
-endif
-
comment "libplayer needs a toolchain w/ threads"
depends on !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/libplayer/libplayer.mk b/package/libplayer/libplayer.mk
index ee5362dc46..ace189180f 100644
--- a/package/libplayer/libplayer.mk
+++ b/package/libplayer/libplayer.mk
@@ -39,9 +39,4 @@ else
LIBPLAYER_CONF_OPTS += --disable-gstreamer
endif
-ifeq ($(BR2_PACKAGE_LIBPLAYER_PYTHON),y)
-LIBPLAYER_DEPENDENCIES += python
-LIBPLAYER_CONF_OPTS += --enable-binding-python
-endif
-
$(eval $(autotools-package))