aboutsummaryrefslogtreecommitdiff
path: root/package/libqmi
diff options
context:
space:
mode:
authorGravatar Patrick Ziegler <patrick.ziegler@fh-kl.de>2013-06-18 16:19:51 +0200
committerGravatar Peter Korsgaard <jacmet@sunsite.dk>2013-06-19 22:51:36 +0200
commit211a5df280ac463da4c8f3ad0539455f206aa04d (patch)
tree5b6f4fb2ae33c17719dd3a809665b869e79e315f /package/libqmi
parente26267ef2e4f4d2548d081fb85428fa45f9c6276 (diff)
downloadbuildroot-211a5df280ac463da4c8f3ad0539455f206aa04d.tar.gz
buildroot-211a5df280ac463da4c8f3ad0539455f206aa04d.tar.bz2
libqmi: new package
libqmi is a glib-based library for talking to WWAN modems and devices which speak the Qualcomm MSM Interface (QMI) protocol. Signed-off-by: Patrick Ziegler <patrick.ziegler@fh-kl.de> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/libqmi')
-rw-r--r--package/libqmi/Config.in9
-rw-r--r--package/libqmi/libqmi.mk16
2 files changed, 25 insertions, 0 deletions
diff --git a/package/libqmi/Config.in b/package/libqmi/Config.in
new file mode 100644
index 0000000000..c5e8a5c37e
--- /dev/null
+++ b/package/libqmi/Config.in
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_LIBQMI
+ bool "libqmi"
+ select BR2_PACKAGE_LIBGLIB2
+ depends on BR2_USE_WCHAR # libglib2
+ help
+ libqmi is a glib-based library for talking to WWAN modems and devices
+ which speak the Qualcomm MSM Interface (QMI) protocol.
+
+ http://www.freedesktop.org/wiki/Software/libqmi/
diff --git a/package/libqmi/libqmi.mk b/package/libqmi/libqmi.mk
new file mode 100644
index 0000000000..911b1a7957
--- /dev/null
+++ b/package/libqmi/libqmi.mk
@@ -0,0 +1,16 @@
+################################################################################
+#
+# libqmi
+#
+################################################################################
+
+LIBQMI_VERSION = 1.4.0
+LIBQMI_SITE = http://www.freedesktop.org/software/libqmi/
+LIBQMI_SOURCE = libqmi-$(LIBQMI_VERSION).tar.xz
+LIBQMI_LICENSE = LGPLv2+ (library), GPLv2+ (programs)
+LIBQMI_LICENSE_FILES = COPYING
+LIBQMI_INSTALL_STAGING = YES
+
+LIBQMI_DEPENDENCIES = libglib2
+
+$(eval $(autotools-package))