aboutsummaryrefslogtreecommitdiff
path: root/package/libqmi
diff options
context:
space:
mode:
authorGravatar Aleksander Morgado <aleksander@aleksander.es>2017-09-06 23:28:34 +0200
committerGravatar Thomas Petazzoni <thomas.petazzoni@free-electrons.com>2017-09-06 23:48:24 +0200
commit5cb40de7ee09338f1e7db03915447434485959cd (patch)
treee33088f825ab996b8ca76c011db0f07df8a9d769 /package/libqmi
parente1c06945eea337ec7f941563d3e0e5f3d7212331 (diff)
downloadbuildroot-5cb40de7ee09338f1e7db03915447434485959cd.tar.gz
buildroot-5cb40de7ee09338f1e7db03915447434485959cd.tar.bz2
libqmi: add optional features
The libqmi library and tools come with several optional features that may be enabled or disabled during build. This patch adds support to automatically enable or disable them based on the presence of the required dependencies for each: * QMI-over-MBIM is enabled if libmbim is selected. * udev support in qmi-firmware-update is enabled if libgudev is selected. * MM runtime check in qmi-firmware-update is enabled if ModemManager is selected (but we don't build-depend on it, the runtime check is done using plain glib2 DBus operations). Signed-off-by: Aleksander Morgado <aleksander@aleksander.es> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/libqmi')
-rw-r--r--package/libqmi/libqmi.mk30
1 files changed, 28 insertions, 2 deletions
diff --git a/package/libqmi/libqmi.mk b/package/libqmi/libqmi.mk
index 917265f4b6..3a3d079a06 100644
--- a/package/libqmi/libqmi.mk
+++ b/package/libqmi/libqmi.mk
@@ -15,7 +15,33 @@ LIBQMI_AUTORECONF = YES
LIBQMI_DEPENDENCIES = libglib2
-# we don't want -Werror and disable gudev Gobject bindings
-LIBQMI_CONF_OPTS = --enable-more-warnings=no --without-udev
+# we don't want -Werror
+LIBQMI_CONF_OPTS = --enable-more-warnings=no
+
+# if libgudev available, request udev support for a better
+# qmi-firmware-update experience
+ifeq ($(BR2_PACKAGE_LIBGUDEV),y)
+LIBQMI_DEPENDENCIES += libgudev
+LIBQMI_CONF_OPTS += --with-udev
+else
+LIBQMI_CONF_OPTS += --without-udev
+endif
+
+# if libmbim available, request QMI-over-MBIM support
+ifeq ($(BR2_PACKAGE_LIBMBIM),y)
+LIBQMI_DEPENDENCIES += libmbim
+LIBQMI_CONF_OPTS += --enable-mbim-qmux
+else
+LIBQMI_CONF_OPTS += --disable-mbim-qmux
+endif
+
+# if ModemManager available, enable MM runtime check in
+# qmi-firmware-update (note that we don't need to build-depend on
+# anything else)
+ifeq ($(BR2_PACKAGE_MODEM_MANAGER),y)
+LIBQMI_CONF_OPTS += --enable-mm-runtime-check
+else
+LIBQMI_CONF_OPTS += --disable-mm-runtime-check
+endif
$(eval $(autotools-package))