aboutsummaryrefslogtreecommitdiff
path: root/package/luaexpatutils
diff options
context:
space:
mode:
authorGravatar Francois Perrad <fperrad@gmail.com>2014-01-17 18:47:36 +0100
committerGravatar Peter Korsgaard <peter@korsgaard.com>2014-01-21 23:27:50 +0100
commit751d85a7f835ab055dd16087991e08a22a14c364 (patch)
treeb38d09aab7091317e5d0154dcafde0d4164ef1ba /package/luaexpatutils
parentba296ab1eaeab5ab68c596f7723932788749c9c6 (diff)
downloadbuildroot-751d85a7f835ab055dd16087991e08a22a14c364.tar.gz
buildroot-751d85a7f835ab055dd16087991e08a22a14c364.tar.bz2
lua-modules: choice between Lua 5.1.x & Lua 5.2.x
Signed-off-by: Francois Perrad <francois.perrad@gadz.org> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/luaexpatutils')
-rw-r--r--package/luaexpatutils/Config.in4
-rw-r--r--package/luaexpatutils/luaexpatutils.mk2
2 files changed, 5 insertions, 1 deletions
diff --git a/package/luaexpatutils/Config.in b/package/luaexpatutils/Config.in
index cb2887acaa..333f98dc32 100644
--- a/package/luaexpatutils/Config.in
+++ b/package/luaexpatutils/Config.in
@@ -1,8 +1,12 @@
config BR2_PACKAGE_LUAEXPATUTILS
bool "luaexpatutils"
select BR2_PACKAGE_LUAEXPAT
+ depends on !BR2_PACKAGE_LUA_5_2
help
lxp.doc is a module that provides useful features for working with
XML formats in LOM format as used by the LuaExpat project from Kepler.
https://github.com/stevedonovan/LuaExpatUtils
+
+comment "luaexpatutils needs a Lua 5.1 interpreter"
+ depends on BR2_PACKAGE_LUA_5_2
diff --git a/package/luaexpatutils/luaexpatutils.mk b/package/luaexpatutils/luaexpatutils.mk
index 93cf621955..9bfc654716 100644
--- a/package/luaexpatutils/luaexpatutils.mk
+++ b/package/luaexpatutils/luaexpatutils.mk
@@ -11,7 +11,7 @@ LUAEXPATUTILS_DEPENDENCIES = luaexpat
define LUAEXPATUTILS_INSTALL_TARGET_CMDS
$(INSTALL) -m 0644 -D $(@D)/lua/doc.lua \
- $(TARGET_DIR)/usr/share/lua/5.1/lxp/doc.lua
+ $(TARGET_DIR)/usr/share/lua/$(LUAINTERPRETER_ABIVER)/lxp/doc.lua
endef
$(eval $(generic-package))