aboutsummaryrefslogtreecommitdiff
path: root/package/metacity/metacity.mk
diff options
context:
space:
mode:
authorGravatar Peter Korsgaard <jacmet@sunsite.dk>2011-02-23 22:37:47 +0100
committerGravatar Peter Korsgaard <jacmet@sunsite.dk>2011-02-23 22:37:47 +0100
commitc25d7e49a94b997144f808c44495d38de507b1e6 (patch)
treef5f74a4318934f9dd0bffca0c4c4746237ee9b46 /package/metacity/metacity.mk
parenta157909eefe1215d9173aa2b76b4bfd7ba1612f9 (diff)
downloadbuildroot-c25d7e49a94b997144f808c44495d38de507b1e6.tar.gz
buildroot-c25d7e49a94b997144f808c44495d38de507b1e6.tar.bz2
metacity: fix build, bump version
Metacity no longer built after libgtk2 was updated, so fix it by bumping the version. We unfortunately cannot move to the latest version, as these have extra dependencies we don't have in BR yet (libcanberra-gtk + gnome-doc-utils). Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/metacity/metacity.mk')
-rw-r--r--package/metacity/metacity.mk9
1 files changed, 5 insertions, 4 deletions
diff --git a/package/metacity/metacity.mk b/package/metacity/metacity.mk
index 9d91efe6aa..04cfa107de 100644
--- a/package/metacity/metacity.mk
+++ b/package/metacity/metacity.mk
@@ -4,11 +4,12 @@
#
#############################################################
-METACITY_VERSION = 2.16.8
+# newer versions need libcanberra-gtk and gnome-doc-utils
+METACITY_VERSION_MAJOR = 2.25
+METACITY_VERSION_MINOR = 1
+METACITY_VERSION = $(METACITY_VERSION_MAJOR).$(METACITY_VERSION_MINOR)
METACITY_SOURCE = metacity-$(METACITY_VERSION).tar.bz2
-METACITY_SITE = http://ftp.gnome.org/pub/gnome/sources/metacity/2.16
-METACITY_INSTALL_STAGING =NO
-METACITY_INSTALL_TARGET =YES
+METACITY_SITE = http://ftp.gnome.org/pub/gnome/sources/metacity/$(METACITY_VERSION_MAJOR)
METACITY_CONF_OPT = --x-includes=$(STAGING_DIR)/usr/include/X11 \
--x-libraries=$(STAGING_DIR)/usr/lib \