aboutsummaryrefslogtreecommitdiff
path: root/package/opencv
diff options
context:
space:
mode:
authorGravatar Spenser Gilliland <spenser@gillilanding.com>2013-07-15 14:47:50 -0500
committerGravatar Thomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-07-27 17:13:37 +0200
commit51788521b7467942a550cb1d077e6550a7472498 (patch)
tree9948eacc6e23b4cd444d96f2693b0cc56e9a6955 /package/opencv
parent3fed58bd509b8dbb1ea5fe088fe92eb8cd86a410 (diff)
downloadbuildroot-51788521b7467942a550cb1d077e6550a7472498.tar.gz
buildroot-51788521b7467942a550cb1d077e6550a7472498.tar.bz2
libglib2: needs threads
This commit adds a dependency of the libglib2 package on thread support in the toolchain, since upstream libglib2 doesn't build without thread support. The commit is rather large as it involves propagating the dependency on thread support to all reverse dependencies of the libglib2 package. [Thomas: squash all patches into one, make a few minor fixes, the most important one being to not add comments about MMU requirement when a package doesn't work on !MMU platforms.] Signed-off-by: Spenser Gilliland <spenser@gillilanding.com>
Diffstat (limited to 'package/opencv')
-rw-r--r--package/opencv/Config.in10
1 files changed, 7 insertions, 3 deletions
diff --git a/package/opencv/Config.in b/package/opencv/Config.in
index 26bf5e79c3..c6ec3fed23 100644
--- a/package/opencv/Config.in
+++ b/package/opencv/Config.in
@@ -139,16 +139,20 @@ comment "ffmpeg support requires a toolchain with LARGEFILE and IPV6 support"
config BR2_PACKAGE_OPENCV_WITH_GSTREAMER
bool "gstreamer support"
- depends on BR2_USE_WCHAR
- depends on BR2_TOOLCHAIN_HAS_THREADS
+ depends on BR2_USE_WCHAR # gstreamer -> libglib2
+ depends on BR2_TOOLCHAIN_HAS_THREADS # gstreamer -> libglib2
select BR2_PACKAGE_GSTREAMER
select BR2_PACKAGE_GST_PLUGINS_BASE
select BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_APP
+comment "gstreamer support requires a toolchain with WCHAR and threading support"
+ depends on !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS
+
config BR2_PACKAGE_OPENCV_WITH_GTK
bool "gtk support"
depends on BR2_PACKAGE_XORG7||BR2_PACKAGE_DIRECTFB
- depends on BR2_USE_WCHAR
+ depends on BR2_USE_WCHAR # libgtk2 -> libglib2
+ depends on BR2_TOOLCHAIN_HAS_THREADS # libgtk2 -> libglib2
depends on BR2_INSTALL_LIBSTDCPP
select BR2_PACKAGE_LIBGTK2