aboutsummaryrefslogtreecommitdiff
path: root/package/openobex/Config.in
diff options
context:
space:
mode:
authorGravatar Spenser Gilliland <spenser@gillilanding.com>2013-07-15 14:47:50 -0500
committerGravatar Thomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-07-27 17:13:37 +0200
commit51788521b7467942a550cb1d077e6550a7472498 (patch)
tree9948eacc6e23b4cd444d96f2693b0cc56e9a6955 /package/openobex/Config.in
parent3fed58bd509b8dbb1ea5fe088fe92eb8cd86a410 (diff)
downloadbuildroot-51788521b7467942a550cb1d077e6550a7472498.tar.gz
buildroot-51788521b7467942a550cb1d077e6550a7472498.tar.bz2
libglib2: needs threads
This commit adds a dependency of the libglib2 package on thread support in the toolchain, since upstream libglib2 doesn't build without thread support. The commit is rather large as it involves propagating the dependency on thread support to all reverse dependencies of the libglib2 package. [Thomas: squash all patches into one, make a few minor fixes, the most important one being to not add comments about MMU requirement when a package doesn't work on !MMU platforms.] Signed-off-by: Spenser Gilliland <spenser@gillilanding.com>
Diffstat (limited to 'package/openobex/Config.in')
-rw-r--r--package/openobex/Config.in18
1 files changed, 9 insertions, 9 deletions
diff --git a/package/openobex/Config.in b/package/openobex/Config.in
index 6494b2952d..c8e1f65878 100644
--- a/package/openobex/Config.in
+++ b/package/openobex/Config.in
@@ -1,6 +1,3 @@
-comment "openobex requires a toolchain with IPV6 support"
- depends on !BR2_INET_IPV6
-
config BR2_PACKAGE_OPENOBEX
bool "openobex"
depends on BR2_INET_IPV6
@@ -12,25 +9,25 @@ config BR2_PACKAGE_OPENOBEX
if BR2_PACKAGE_OPENOBEX
-comment "bluez support require a toolchain with WCHAR and thread support"
- depends on !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS
-
config BR2_PACKAGE_OPENOBEX_BLUEZ
bool "enable bluez support"
depends on !BR2_avr32
depends on BR2_USE_WCHAR # libglib2
- depends on BR2_TOOLCHAIN_HAS_THREADS # dbus, alsa-lib
+ depends on BR2_TOOLCHAIN_HAS_THREADS # dbus, alsa-lib, libglib2
depends on BR2_USE_MMU # dbus
select BR2_PACKAGE_BLUEZ_UTILS
-comment "libusb support require a toolchain with thread support"
- depends on !BR2_TOOLCHAIN_HAS_THREADS
+comment "bluez support require a toolchain with WCHAR and thread support"
+ depends on !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS
config BR2_PACKAGE_OPENOBEX_LIBUSB
bool "enable libusb support"
depends on BR2_TOOLCHAIN_HAS_THREADS
select BR2_PACKAGE_LIBUSB
+comment "libusb support require a toolchain with thread support"
+ depends on !BR2_TOOLCHAIN_HAS_THREADS
+
config BR2_PACKAGE_OPENOBEX_APPS
bool "install test applications"
help
@@ -43,3 +40,6 @@ config BR2_PACKAGE_OPENOBEX_DUMP
bool "enable protocol dumping for debugging"
endif
+
+comment "openobex requires a toolchain with IPV6 support"
+ depends on !BR2_INET_IPV6